X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I know which Java update is the right one for my system

Posted

Hello Can anyone tell me what the right update is for Java (TM) Platform SE7 U5, as my Firefox is warning me it is critical I update due to security and vulnerability issues. I am just a bit confused because when I click to update it takes me to a page about the different operating systems and I'm not sure which is the right one for me. I have a 64 bit operating system, so if anyone could provide me with a link to the right place to download I will be eternally grateful. Thanks

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • SiteAdvisor
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • McAfee MSC FF plugin DLL
  • Motive Plugin for Mozilla Browsers
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • BlackBerry WebSL Browser Plug-In
  • NPWLPG
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Helpful Reply

http://javadl.sun.com/webapps/download/AutoDL?BundleId=73141

Question owner

Hello Tylerdowner

Thanks for the link to click but having done so my system is telling me I already have this update. What I don't understand is why isn't it showing up as updated in my add-ons, all it does say is I need to update and that it's critical I do so as a matter of security. Can you help me clear this up as I don't want Firefox crashing and not be able to get back in because of it ?

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

If you type about:addons into your address bar, press enter, and go to plugins, do you have update 11? Use http://ninite.com/flash-java-reader/ninite.exe to try again. Make sure Firefox is closed and you restart your PC.

Question owner

Hello again Tylerdowner

Thank you for the latest solution to my problem but having tried it exactly as you said it made no difference to my addons. Whilst the link you sent me was downloading I got an error box pop up which said "There was a problem starting C:\ProgramFiles\Java\jre7\bin\installer.dll The specified module could not be found". I'm at a loss at what to try next it's the only one of my addons that is showing critical that I update it. Please feel free to offer me another solution as I don't want my PC crashing due to a out of date addon, and thanks for trying thus far. P.S Do you want me to find out what the addons number is ?

Modified by Jumbochick

Question owner

Hello Tylerdowner

Just a re-cap on my Java issue my Java is now showing up to date in the plugins list, but not in my addons list. I don't know what I have done to it to make it show updated in my plugins, but it's a bit strange that it is showing that it needs a critical update in my addons. All I need to know now is how to make it show up to date in my addons, so if you have any ideas please feel free to make a suggestion. Thanks for the help so far.