X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Latest version of Firefox for Android will no longer work with Citrix Receiver.

Posted

Previous v.17 works, current version will not download ica file and gives me a message that the server is not recognized. I have deleted and reinstalled Citrix Receiver and RSA SecurID and company provided soft token. I get past the security and into CitrixXenApp(?) where I can see my various company programs. However, when I attempt to open a program the Rica file isn't downloaded and I get the error/warning message... Any help short of keeping v.17 available for reinstallation, thanks!

Additional System Details

Application

  • User Agent:

More Information

AaronMT 31 solutions 241 answers

What was the error/warning message? If you uninstall and reinstall Firefox on Google Play does this fix the problem for you? Can you also try Firefox Beta on Google Play? Does that work?

If nothing else, you can find Firefox 17 in our-past release section on the Mozilla FTP at http://ftp.mozilla.org/pub/mozilla.org/mobile/releases/17.0/android/multi/