X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

YouTube loads black screen for first five seconds

Posted

Starting early January 2013 in Firefox, YouTube videos are loaded as blank black screens for the first five seconds. At the 0:06 mark, videos start playing normally. This is not an issue in Chrome or IE. Tested with all plug-ins and add-ons disabled (except Flash player). Plug-ins/add-ons updated. Tried re-installing Firefox with no solution. Help? Thanks!

Modified by jackjbt

Chosen solution

You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version 3.10.2.10212
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Chosen Solution

You can check for problems caused by recent Flash updates and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in Flash 11.3 and later
  • disable hardware acceleration in the Flash plugin

Question owner

Disabling hardware acceleration in the Flash plugin worked.

Right click on YouTube video with playback issues, select "Settings...", uncheck hardware acceleration.

Thanks!! Hope this helps others, too.