X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The Firefox browser is so slow on my CNN homepage it can't be used. I've emptied cache, repaired permisions, everything a Mac can do. It

Posted

Using a desktop Mac running OSX10.6.8 CNN is my homepage on Firefox 18.0. It has become so incredibly slow with video, even text links, it is unusable. I have reset preferences, emptied cache, repaired permissions....everything I can find recommended. Chrome handles the same tasks quite efficiently. Is it me ... or is the software burdened with bugs?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Version 3.11.7.10909
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Office Live Update v1.0
  • WebEx64 General Plugin Container Version 205
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX Web Player version 2.0.2.39
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
416 solutions 4930 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

Try to disable hardware acceleration in Firefox.

You can use one of these to start Firefox in Safe mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled