X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

homepage loads to wrong country

Posted

All of a sudden mozilla loads to the netherlands not United States. How do I fix this. It also doesnt recognize my computer with yahoo homepage.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Google Update
  • 5.1.10411.0
  • Picasa plugin
  • NPWLPG
  • GEPlugin
  • Yahoo Application State Plugin version 1.0.0.7
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3018 answers

This is possible with your ip address or that you have installed an add-on recently causing this to happen.

Please check your ip with http://www.whatismyip.com/

Also here are the steps for safe mode:

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.