X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I turn off/disable the plugin check? Java is not installed.

Posted

How do I disable the plugin check at Firefox start up? All of my plugins are up to date and I do not have Java installed on my system (thus, do not have the Java plugin).

I'm running FF 12 and have already set plugins.update.notifyUser to False.

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Google Update
  • Shockwave Flash 11.2 r202
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:6.0.1) Gecko/20100101 Firefox/6.0.1

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

You are actually running Firefox 6.0.1. Please update to Firefox 18. Update Firefox to the latest version


Then, your Flash is out of date, you are running Flash 11.2 when the latest version is 11.5. Please update that.

Question owner

I'm posting from work. My question refers to my home PC.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

The reply remains the same, please update to Firefox 18, and Reset Firefox. (and you should update that ancient work machine)

Question owner

Man, I hate upgrading my browsers so often. Especially since my browsing habits are incredibly tame. Oh well, I'll upgrade to 18 and report the results.

And, I actually wish I could update my work machine but that's not possible.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

If you actually upgrade to Firefox 18, turn on automatic updates, Firefox will check for and install updates without you even seeing a thing, totally silent and painless.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

And talk to your work IT department, as having such an old version of Firefox on that machine is leaving your whole company network vulnerable to attack.

Question owner

I'm one of those curmudgeons that doesn't like software updating itself in the back ground. I prefer to choose when updates happen.

Regardless, upgrading to 18 worked. Thanks.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

Note that by not letting Firefox update in the background you are increasing the chances you'll be running a vulnerable version of Firefox if there is a zero-day. Just look at the vulnerabilities that have been fixed in recent versions https://www.mozilla.org/security/known-vulnerabilities/firefox.html

Alcuin 0 solutions 1 answers

Helpful Reply

@Tylerdowner, you're not my mother. You posted 5 times and never answered the question. That's not helpful. ANSWER THE QUESTION. Then if you want to warn me about the risks I'm running, that's ok. But answer the question first.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Which plugin do you have on the home computer?

If there are plugins among them that were blocklisted by Mozilla then that can be the cause of getting the plugin check page.

I'm on Linux and blocking plugin is for Windows (and Mac), so I can't check if you can disable this apart from disabling blocklisting completely and that is not a good idea.

systemerror 0 solutions 1 answers

hello, just deleted all xml files in c\program files\mozilla\plugin

it worked /// im using Win 7

jetlover 0 solutions 1 answers

set plugins.update.url to blank (no url). copy the url first to notepad and use it when you want to update plugin.

plugins.update.notifyUser will always set true after you set to false.

Modified by jetlover