Question

Firefox can not handle ClickOnce generated publish.htm page.

I've deployed my application with ClickOnce. When I go to the deployed site produced by ClickOnce (..\publish.htm), Firefox displays the site properly. However when I click the "Launch" hyeperlink there, all I get is a page-full of XML listing. What's supposed to happen is that Firefox should launch the application subject to the specified prerequisites.

I have tried three different machines (2 running XP Pro, 1 running Vista Ultimate) and the same thing happens.

If you want to check, the site I'm testing is at www.abbeycontrols.co.uk. Navigate to "Applications & Calculators" and click the application there: http://www.abbeycontrols.co.uk/abbey/applications/IgnitionBox/publish.htm

My machine runs Vista Ultimate SP2 but I have tried it on other machines running XP Pro SP3. Same problem. I had similar problem with Internet Explorer but this has now been fixed by changing the "Compatibility View" settings. I can't find similar setting for Firefox. Google Chrome has the same problem but I'll take this up with Google.

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • post
  • owner
  • post