X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Plugin check page says I need to update Google Earth, but the link doesn't work.

Posted

This question came up before. Pineman gave a useful link. I went there. I was told that I have the plug-in version 6.1.0.5001 installed. Isn't that the latest? If so, why doesn't Firefox know that?

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Google Update
  • Amazon MP3 Downloader Plugin 1.0.17
  • 5.1.10411.0
  • GEPlugin
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Madasan
  • Administrator
  • Moderator
6 solutions 65 answers

Hi bobgustafson,

You might want to re-open the old thread and ask your question there as the people who were participating in the discussion won't be able to see your question.

I believe this is the one: https://support.mozilla.org/en-US/questions/925671?