X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Get rid of the marketplace.firefox,com site that keeps downloading on start up

Posted

This website loads an ad for downloading to Android which I don't have and it's a nuisance. I've tried blocking it without success. This ad loads before my home page and I have to close it before I can do anything else.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • npsitesafety
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • 5.1.10411.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.615
  • Office Live Update v1.5
  • NPWLPG
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3019 answers

Does this occur on another browser on your mobile device? Can you try uninstalling Firefox then reinstalling it on your mobile device to see if it helps or not?

Question owner

I don't have a mobile device - that's why it's a nuisance. No other browser either.

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3019 answers

This could be set as your homepage? See How to set the home page to check.

Question owner

Firefox is my default browser and it's connected to that somehow. I have Yahoo as my homepage. This program showed up when I downloaded the latest version of Firefox.

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24404 answers

Your homepage has nothing to do with Firefox being your default browser. Did you read the hyperlinked support page?

Question owner

I've read so many pages and nothing explains how to get rid of Marketplace.firefox.com

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96811 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

So your home page setting is correct?

If you do not keep changes after a restart then see:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Modified by cor-el