Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Facebook crashes firefox even in safe mode


For some reason, starting today, every time I attempt to open Facebook, Firefox crashes. This occurs even in safe mode. I am running 18.0 on Mac OS X 10.8.2. All plugins are up to date.

Last 5 crash reports:


Modified by cor-el

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.5 r502
  • Version
  • Google Talk Plugin Video Accelerator version:
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Office Live Update v1.0
  • 5.1.10411.0
  • DivX Web Player version
  • npmnqmp 071505000006
  • Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com
  • iPhoto6
  • 3D Life Player Plug-In : Plays Virtools File in your browser!


  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

kgarlich 0 solutions 1 answers

Helpful Reply

I am having issues with Facebook too. I'm on a Mac running OS X and everytime I go to FB, I get a script error. The errors are different each time. Today's was: Script: https://fbstatic-a.akamaihd.net/rsrc.php/v2/yG/r/rEq55HRbeKE.js:52.

I have repeatedly reset my cookies and cache to no avail.

Question owner

It inexplicably stopped crashing for a little while, then just as inexplicably started again despite me not downloading any addons or plugins in the interim.

Is anybody reading this?

Most recent crash reports:


Modified by cor-el

  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

That could be a problem with a plugin (Java?).

Note that Safe mode doesn't disable plugins.

Question owner

...huh. I turned all my plugins off, starting with Java, then Flash, then Quicktime, then Silverlight, then everything else. After that it worked, so I turned all my plugins back on one by one. It still worked by the time I got them all turned back on, leaving me with no clue as to which plugin was causing the problem in the first place. Maybe there's something in those crash reports that I can't make head nor tail of?

  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

It could have been a problem with the pluginreg.dat file or another file in the Firefox Profile Folder that got rebuild as the result of your efforts. Anyway glad that you managed to get it working better.

nancybhenry 0 solutions 3 answers

This solved my problem.

1. Close Firefox completely 2. Click on Start | Run | Type “firefox.exe –p” without quotes 3. Click OK 4. Click on Create Profile | Choose the user Profile Window. 5. In Create Profile Wizard click on Next. 6. Type the name in New Profile Name and Click on Finish. 7. Uncheck Don’t ask at Startup and click on Start Firefox.

This newly created user profile would appear whenever you start Firefox web browser. If you do not want to see this Window quite often, uncheck this Window.

Read more: http://digitaljournal.com/blog/15416#ixzz2Mmamk3hJ

Cuckooparachute 0 solutions 1 answers

Helpful Reply

Fixed this (after trying everything) by disabling the Facebook Desktop Add-on. Go to:

  • Tools/Add-ons
  • Find Facebook Desktop
  • Click disable.

Modified by Cuckooparachute

  • Top 25 Contributor
  • Moderator
622 solutions 8043 answers


There is apparently a known issue that is being worked on by Facebook developers.

From (sumo)meeting notes https://etherpad.mozilla.org/sumo-2013-03-11

  Firefox Desktop
  Facebook crashes - Caused by the Facebook Desktop plugin. The developer has pushed an update. Users should all be on the newest version in the next few days

There could be a bug filed on this, but I did not find it.

Meanwhile snowy88 has posted elsethread, and Cuckooparachute has posted above that the workaround is to disable the Facebook Desktop plugin.