X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

about:home search broken

Posted

Since a couple of days ago I noticed something weird with my start page. Usually I see mozilla related content under the search box, which is gone, while typing something into the search box and pressing the button or enter does nothing. I already tried resetting browser.startup.homepage_override.mstone and deleting the chromeappsstore.sqlite with no effect. I would like a solution that doesn't involve making a new profile consindering that I don't want to lose all my bookmarks and addons. This is not a major problem for me as I can search from the navigation bar, but I would like to fix it.

Chosen solution

What is the values of the browser.search.defaultenginename pref on the about:config page?

That search engine is used in current Firefox versions for the about:home page.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • VLC media player Web Plugin 2.0.2
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • 5.1.10411.0
  • Unity Player 3.5.0f6
  • QUAKE LIVE
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 0.80.0
  • 0.70.0
  • NPWLPG
  • Yahoo Application State Plugin version 1.0.0.7
  • np-mswmp
  • Yahoo! activeX Plug-in Bridge

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24455 answers

If you use the Search Bar, you can clear only Search History by right-clicking in the Search Bar and using Clear Search History menu-item. Not 100% sure if that also clears the "history" in about:home, but please try that first.

If not, you can clear your Form and Search History under Firefox button > History -> Clear Recent History = then make sure that only Form and Search History is check-marked. Otherwise you'll end up deleting all your Recent History. Unfortunately you can't clear Search History alone from there. That I know will clear the accumulated history of searches in the about:home search box.

Question owner

I did that, nothing changed. I don't see how search history is related to my issue, I think it's a bit more complicated than that. The bottom buttons (downloads, history, etc.) on the about:home work, only the "search" button does nothing. I think there's an issue with maybe the html file or with the java script but I don't know how to troubleshoot those.

the-edmeister
  • Top 10 Contributor
  • Moderator
3202 solutions 24455 answers

Sorry, I misread your problem.

Another user reported that TabMix Plus was causings a similar issue for him; the Search Box was dead.
https://support.mozilla.org/en-US/questions/946650?esab=a&s=Firefox+18+about%3Ahome+search&r=6&as=s

Any chance you have TabMix Plus installed?

Question owner

The only tab addon that I have installed is New Tab Plus. I use about:home only as my start page. Tried with addons disabled with no effect.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Chosen Solution

What is the values of the browser.search.defaultenginename pref on the about:config page?

That search engine is used in current Firefox versions for the about:home page.

Question owner

browser.search.defaultenginename: Status - User set / Type - string / Value - Web Search

I noticed that my work pc firefox has the google logo on the left of the search box, while on my personal one that's missing. Maybe an issue with the search engine?

Question owner

I had reset the value of browser.search.defaultenginename to Google and it's now working. Seems like something changed that value. Thanks for your help Cor-el !!

Davo1 0 solutions 5 answers

Please someone explain properly how to do this, we are not all tekkies!


thanks davo

ps This has happened only since FF update two days ago but is V annoying

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Helpful Reply

Type about:config in the location (address) bar and press the "Enter" key to open the about:config page, just like you open a website by typing the URL in the location bar.

  • If you see a warning message then you can confirm that you want to access the about:config page.
  • use the Search bar at the top of the about:config page to locate preferences more easily
  • preferences that have been modified and do not have the default value show as bold (user set)
  • preferences that are user set (bold) can be reset to the default value via the right-click context menu
  • preferences can be changed via the right-click context menu: Modify (String or Integer) or Toggle (Boolean) or by double-clicking the line with the pref
  • preferences can be created via the right-click context menu: New -> String, Integer, Boolean

See also:

In this case you can check the value of the browser.search.defaultenginename pref, but you probably can do this in a much easier way with the SearchReset extension.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Davo1 0 solutions 5 answers

Hi cor-el

There was a mstone override value of 20.1.01again today disabling the search

davo

I think I need to go back one version

Davo1 0 solutions 5 answers

Both overrides changing, getting fed up now. No new software or add-ons updates to cause this

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

The browser.startup.homepage_override.mstone pref will always store the current Firefox version.
A reset of this pref makes Firefox reset some specific files in the profile folder just as happens when Firefox gets updated, so no worries if you se the same value appearing again.
It shouldn't be necessary to perform this action frequently as that may indicate that something else is wrong and you may have security software causing problems.

Davo1 0 solutions 5 answers

Hi cor-el

Been thinking I recently switched from Norton to a trial of bitdefender. Strangely, I have a google toolbar on at the top and this is not affected

davo

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

The search bar on the about:home page uses the browser.search.defaultenginename pref, so you can check if this pref still has the default value Google.

You can check if you still have the XML files of the default search engines including Google in the searchplugins folder in Firefox program folder.

You can delete the search.json file and a possible search.sqlite file in the Firefox profile folder.

Firefox will rebuild the search.json file from the default search engines in the searchplugins folder in the Firefox program folder and the searchplugins folder in the Firefox profile folder.

Davo1 0 solutions 5 answers

Hi cor-el

yes, google is still there.

deleted json, other one not there.

Switched to Kaspersky trial but problem still persists. Switched to version 20, same thing

Only noscript has updated of my add ons

davo