Question

This version of Firefox [1.5] is not supported by Norton

The above "Question This version..." is part of the problem, but it is complicated by the fact that on your "feedback" page, the "Submit" button does not work--period. I tried approaching by different routes, but all led back to the page where neither feedback nor questions could be submitted.

BTW, I have tried all the suggestions re resetting, clicking on the "I'll be careful..." option, emptying cache, cookies, etc. to no avail.

My original attempt at feedback, which was impossible to submit: For over a year, every time I attempt to start Firefox [generally through its start page http://www.google.com/firefox?client=firefox-a&rls=org.moz... I get the message that Norton Security will not be able to protect me because I am on version 1.5. I am on version 18.0, and the problem persists. One or both of you has to go--this has been going on much too long. I just need to find out which of you is the problem.

Now, when I click on the “Submit” button, it does not work.

Sorry--Firefox was a great browser while it worked, but this is quite unacceptable.
↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • helpful