X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

FF18.0 Mac OS. right click (control click) on left half of an additional display brings the menu up in small font on the laptop

Posted

Upgraded to FF18.0 from the prior version (Mac OS 10.8.2) and it works great on my MacBook Pro Retina display. However, if either a 27" Thunderbolt Display or 27" LED Cinema Display is also plugged in and the browser is on the separate display there is a problem:

Right or control clicking the browser window anywhere on the left half of the separate display brings the pop up menu on the laptop in very small font (presumably at the higher resolution of the separate monitor). The problem also occurs with links on web pages that have preview pop ups when you hold the cursor over the link.

These were not issues in the FF17.x version I was previously using.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Apple Connect Plug-in
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Displays Java applet content, or a placeholder if Java is not installed.
  • WebEx64 General Plugin Container Version 205
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • NDS Player Plugin
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • DivX OVS Helper Plug-in
  • DivX Web Player version 2.1.0.900
  • RealPlayer Plugin
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Try to disable hardware acceleration in Firefox.

[edited to fix incorrect Tools > Options menu link]

Modified by cor-el

Question owner

Thank you for trying to solve this problem for me but this doesn't fix it. (btw in 18.0 for Mac OS the hardware acceleration option is in Preferences>Advances)

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

You can try out the Firefox 19 beta to see if that still has this problem.