Question

pop up message: Norton Confidential cannot protect you while you use this version of Firefox(18.0 current). Phishing Protection requires Firefox 1.5 or later(?

I am currently using Firefox version 18.0 yet when I open Firefox, I always get this pop up message: “This version of Firefox is not supported by Norton Confidential. You will not be protected while browsing the Web. Norton Confidential cannot protect you while you use this version of Firefox. Phishing Protection requires Firefox 1.5 or later.” Do you know what is causing this? This started when I updated to Firefox 16.0.2. Am I at risk?

↓ Show more ↑ Show less
  • All posts
  • Helpful Solutions
  • helpful
  • post
  • post
  • helpful