X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox became really slow, sluggish and monopolizing CPU (92% usage) and RAM (8GB) after upgrading to 18 .Mac Lion OS X 10.8.2 MacBook 13inch Retina 11/2012

Posted

I upgraded two days ago to Firefox 18 from 17. Firefox used to run very smoothly on my system. Now the application hangs, the cursor and the scrolling lag, and when I type in text in form areas there is a noticeable delay. I ran a complete virus scan with Sophos and looked at the resource usage. The CPU usage (this is a dual core processor) nears 92% for Firefox. Same for the memory (I have 8GB of RAM) even when Firefox is the only application running.

Chosen solution

It did help, thank you.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

More Information

Ran virus scan and the system is clean.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Chosen Solution

It did help, thank you.

afriend 0 solutions 1 answers

I'm not the original poster but have the same issue which does not go away with Reset method suggested above, neither by disabling all add-ons or so. I guess it's more than that and I hope it is going to be resolved in the upcoming update or you may provide us with another solution.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Helpful Reply

Try to disable hardware acceleration in Firefox.


  • Mac: Firefox > Preferences
  • Linux: Edit > Preferences
  • Windows: Firefox > Options

Press F10 if the menu bar is hidden on Windows and Linux or use "Firefox > Options/Preferences"

dweedow 0 solutions 1 answers

I have a similar problem. Firefox does not consume too many resources. It barely uses them as usual. It also does not stop responding. The program itself responds, but it just does not load pages. If at all it takes 10 minutes or so to load. I'm typing this response from chrome. I have tried resetting firefox with no luck and I have also tried unchecking the hardware acceleration box, although I don't see how that would be a problem. The problem exists solely in the 18.0 update that firefox downloaded automatically. Any help would be appreciated. I would hate to lose everything I've put into firefox. A little more information, I am not using themes or anything like that, just the basic browser with mostly default settings and a few addons.

Question owner

@Dweedow. Thank you for your response. Your issue seems a little different from the one I had experienced since, in my case, the main issue was the monopolization of the CPU resources. The reset worked in my case. So I am not sure what to suggest. I

1394 0 solutions 7 answers

Helpful Reply

I use FF always with many tabs opened, min 100, sometimes up to 300+. After Updating FF17 to FF18 I've recognized a much more higher CPU-usage.


This issue doesn't occur as long as there are just a few tabs opened, or it doesnt' be of any consequence at least. The CPU-load of FF18 gets higher with each opened tab. When you close the tabs, the CPU-usage also gets normal. There is nearly no Flash-content and just few JS working on the websites (thanks to NoScript and ABP).


The System: i5-CPU, 16GB RAM, Win7 x64

FF17.01: CPU-load 1.0% average at 300 tabs

FF18.01: CPU-load 10.0% average at 300 tabs FF18.01: CPU-load 5.0% average at 150 tabs FF18.01: CPU-load 3.3% average at 100 tabs


A fresh install and disabling all addons (even in Safemode) didn't fix the problem. It seems, that FF is permanetly doing something with the tabs to being able to speedup on user-action. It's all good, as long as there are just a few tabs opened, but it's getting worse with each further opened tab.


I've opened a bug-ticket at https://bugzilla.mozilla.org/show_bug.cgi?id=832864

WindsurferLA 1 solutions 3 answers

My computer resource hogging problem, like some of those above, seems to be associated with update from 17 to 18.

In an attempt to cure the problem, I used Add/Remove programs to remove Firefox and downloaded a fresh copy; it did not help. What was surprising was that Firefox continued to run and nearly totally monopolize WinXP resources (3 Ghz dual processor with 4 GB RAM) even after the application was closed via [ File | Exit ]. The situation was so bad that I had to use the Chrome browser to research my Firefox issue.

Per suggestion above, I went to [ Help | Restart with Add-ons disabled ] to restart FireFox in the test mode. Inasmuch as it is working ok with the Add-Ons disabled, I now need to figure out which Add-On is causing the problem.