X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

All pages contents are diagonal (text, pictures, buttons...)

Posted

when i open firefox, the home page loads, but everything is diagonal, and it's the same for every page, they load but all the contents are diagonal. an example: i see a button that should be in a corner standing in the middle of the page and when i want to click on it, the text from the button appears near it so i have to click there to load this content. it's like the button and it's picture are separated and everything it's diagonal, even the text is italic.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9

More Information

Nathan2055 11 solutions 110 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Can you type about:support into the address bar in Firefox, press Enter, and copy and paste that information here? Also, try to disable Hardware Acceleration. Turning off hardware acceleration

eitri 0 solutions 1 answers

I just fixed this issue on a client's computer running MacOS 10.6 (no updates) and Firefox 18.0.1.

The solution ultimately ended up being to install Apple's software updates. After updating to 10.6.8 the problem seems to have disappeared.

Hope this helps!