X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Update 18 slows down my computer.

Posted

I installed firefox update 18 this morning and right after restarting firefox my computer became slow.

Chosen solution

Hello cjstrider, try to Turn off hardware acceleration, and check it again (in safe mode hardware acceleration is disable).

thank you

Read this answer in context 17

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.97 Safari/537.11

More Information

I started firefox in safe mode and my computer was no longer slow. I tried to remove all add ons one by one but firefox remained slow. I chose to reset firefox thinking that it would solve the problem but my computer remained slow. Can someone please help me? I use firefox for all my work related duties. Thanks.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Chosen Solution

Hello cjstrider, try to Turn off hardware acceleration, and check it again (in safe mode hardware acceleration is disable).

thank you

Question owner

Thanks for the reply! It is working now! Thank you so much!

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Helpful Reply

you are welcome

TyD59 0 solutions 2 answers

On my PC it helped but still is a severe problem. On this XP Pro i5-2540M CPU (4 core) 2.6GHz laptop. Toggled Hardware accelerator off & OK, opened advanced again and turned it back on & OK. Rebooted machine. It __now is only a problem on my alternate extended screen__. I believe it is is better, but it still makes using Firefox on my alt screen about useless. A separate browser on the other main screen works fine. When pointer is moved over anything that can be clicked or moved, it hesitates for about 1 entire second. Browser shortcuts, menus, links, scroll bar. Even typing in this reply window is severely delayed.

C'mon Ver 18.01 !!!

Modified by TyD59

lifeoreily 0 solutions 1 answers

Thanks for this post TyD59, I tried moving Firefox to the primary and secondary monitors and have the same problem that you described. My hardware and software are comparable to yours. FF18.0.2 works fine on my main screen, but as soon as I move it to the secondary one, mouse movement gets choppy and the whole system is sluggish. Move it back and everything is fine. It does not matter if the main is analog or digital, I swiched back and forth with the same result. Disabling hardware acceleration in FF fixed the problem completely. Tools > Options > Advanced > General > Browsing: Uncheck "Use hardware acceleration when available"

Modified by lifeoreily

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8028 answers

Probably worth starting a separate thread on the twin screen problem, or searching for answers relating to that. (if so maybe cross link back here).

Unfortunately the native search even advanced search on this forum is not good it will not seach for strings, maybe try a google search - but that is I think limited to open questions so you will not easilly find older solutions and bugs.

TyD59 0 solutions 2 answers

@lifeoreily I finally found that turning off hardware acceleration in the settings fixed it. I think some people said to toggle it off and back on. I just keep mine off in Firefox now and everything works as it did before Ver 18.0 I hope it works for you too ! -TyD59

hrhonda38 0 solutions 1 answers

My games are running fine at first then as i begin to play them they slow down and act like they are in slow motion...I am not computer smart can someone please tell me how to fix this????