X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

YouTube videos won't play.

Posted

I have Firefox 18. I have the latest Adobe Flash installed (after doing a full uninstall and reinstall). I have cleared the cache, cookies, etc.

No matter what I try, YouTube videos will not play in Firefox. I always get the same message:

"An error occurred. Please try again later."

If I copy the exact same link into Explorer (which I normally detest using) it plays perfectly. So clearly the fault lies with Firefox.

What can be done to fix this bug?

Chosen solution

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Read this answer in context 60

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • 0.3
  • Uplay PC Plugin
  • VLC media player Web Plugin 2.0.2
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Pando Web Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • Unity Player 3.5.0f6
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Chosen Solution

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

philipp
  • Top 10 Contributor
  • Moderator
2048 solutions 8914 answers

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Question owner

Tried that, still not working.

The only add-ons I have going are:

Adblock Plus 2.2.1 Java Console 6.0.33 SQLite Manager 0.7.7 DivX Plus Web Player HTML5

I've tried with and without the add-ons running, and nothing seems to work. I've had these add-ons going for ages, but it's only recently (basically since the last time Firefox updated) that YouTube has stopped working.

Question owner

Oops, double post.

Modified by AdamTaylor

Stlheadake 0 solutions 1 answers

I'm having the EXACT same problem. I have downloaded latest flash, uninstalled and then re-installed Firefox 18. Tried safe mode (FF) and they still won't play.

They worked fine just the other day, I don't know what is up!

HELP!!

CCGT500 0 solutions 1 answers

Helpful Reply

I was having the same issue for a VERY long time, probably over a year. I kept using other browsers to watch videos. Finally, I got sick of it and started messing around with add-ons in Firefox. I noticed that I had 3 add-ons for Shockwave, Shockwave Flash 11.5.502.146, Shockwave for Director 11.4.6.634, and Shockwave for Director 11.6.7.637. I disabled the first two, Shockwave Flash 11.5.502.146 and Shockwave for Director 11.4.6.634, and left the last one, Shockwave for Director 11.6.7.637, enabled. It fixed my problem immediately. Go to Tools-Addons in Firefox and disable the 2 add-ons I have mentioned. It worked for me.

webcowboy 0 solutions 3 answers

I am having the problem and it just stated recently, after upgrading to Firefox 18. I have followed all the suggestions here and nothing has corrected the problem.

The only difference in my problem is that I don't get an error message when the Youtube videos don't play on a website; they just don't start playing. Yet I can go to Youtube's website and they play just fine there!

I have never had problems before, and none of the suggested fixes work. I have uninstalled Firefox 18 and Adobe Flash numerous times, even installed 17 that I had no problems with, upgraded Adobe Flash, tried Firefox in protected mode, reset Firefox, disabled add-ons, everything I've seen suggested, and nothing works!

This is so frustrating after three wasted days of trying to fix it and nothing helps!

Oh, and I forgot to add the the Youtube videos play on a website using I.E.10!

Oops, correction, they play on some websites and not on others using I.E 10, but none play on on a website in Firefox. What can be wrong?

Modified by webcowboy

kendra30752 0 solutions 2 answers

Helpful Reply

Okay I found a fix for my own issue with this. I tried EVERYTHING that had been posted here & in three other different forums on this same topic. Nothing worked for me. My problem was random YouTube videos would not play. I'd just be seeing a plain black screen, nothing more. But some would play, so it didn't make sense. This went on for weeks & lastnight I really needed to watch a particular video & decided I'd just do whatever I needed & finally try and fix it. As I said, I tried all the "solutions" listed here & elsewhere. I see that many people had their problems with the videos solved by these solutions, but some like me, said they still had the issue of videos not playing.

Here is what seemed to have fixed it for me: I followed one instruction here saying to uninstall RealPlayer. I did that, no help. Then I thought well, crap! What if I actually needed RealPlayer & that just causes more problems, so I ended up going back and re-installing RealPlayer from the website, which took a few minutes. However, I went one more time immediately after re-installing RealPlayer to see i a video would work & what do ya know? It worked!

I haven't went back and tried viewing videos today, but lastnight after re-installing RealPlayer & going back to one of the videos that never would play before, I was able to watch it, so I began trying to watch multiple others just to be sure. It worked! So it seems my own issue was something to do with RealPlayer.

So if some of you are in the same situation & find that none of these other solutions work, maybe try uninstalling your RealPlayer from your computer, then going to the website for RealPlayer & re-installing.

Hope this helps someone. I was so frustrated lastnight & when I seen that my fix was not listed anywhere online in regards to this problem, I figured I'd come back here today & post it just in case it's helpful to someone else. Maybe it'll save someone the time I spent?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96971 answers

This can be caused by extensions that block content or block cookies and other data.

If you use extensions (Tools > Add-ons > Extensions) like Adblock Plus or NoScript or Flash Block that can block content then make sure that such extensions aren't blocking content.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)
webcowboy 0 solutions 3 answers

I finally found a partial fix. When I disable the Shockwave Flash plugin, then Youtube videos embedded on a website will play, and they always did play on the actual Youtube website. However, once that plugin is disabled, then other video types will not play anywhere! I've tried every suggestion listed here and nothing solved the problem completely. And all of this started with the new Firefox 18. So, I've just resolved to stop wasting hours trying to fix it, and when I'm needing to watch an embedded Youtube video, take 3 seconds to disable Shockwave Flash plugin, and when I'm needing to watch any other type of video, quickly enable the plugin again. Sure wish things were the way they used to be, though!

wgmac 0 solutions 1 answers

I had same problem in Youtube and Facebook. Tried lots of things. What finally worked for me was: 1. Uninstalled Firefox. 2. Uninstalled Flash Player by running the uninstall utility from the Adobe site. 3. Did a search on system drive for all folders containing "Mozilla" in their names and deleted them (to make sure no old settings files remained). 4. Did a search on system drive for all folders containing "Macromedia" in their names and deleted them (except for the Google/Chrome related Macromedia folder). 5. Ran Ccleaner on file system and registry. 6. Reinstalled Firefox. 7. Reinstalled Macromedia Flash Player.

Now videos play on both Youtube and Facebook. I'd had this problem for about a week. HTML5 videos played if the Flash Player (at least if the Flash Player was disabled). I had tried doing just a clean reinstall of the Flash Player after deleting all macromedia folders, but even that did not work. I did not try reinstalling Firefox without deleting all the other Mozilla folders/files remaining after uninstalling it. My experience with other software has been that the problem sometimes lies in files that get left behind and then reused after a new install.

wilcha 0 solutions 1 answers

I had the very same problem.seems to be pretty common.Tried uninstall. /instal Firefox also Flash Player,but nothing changed, The answer I found was to uninstall Real Player, then clean up the registry with cc cleaner and re instal Real Player.It would appear that the Real Player plug ins were causing the trouble, Hope this is helpful to a few sufferers.

webcowboy 0 solutions 3 answers

This is the weirdness thing. Suddenly, everything just started working again, videos of all sorts! Figure that one out!

ilikeABC 0 solutions 1 answers

For a few weeks now, videos just would not play in Firefox but would in other browsers. I tried the recommended solution, to reset Firefox, but that did not work. I tried uninstalling, and reinstalling, but that didn't work either.

What did work was updating RealPlayer.

According to my Add-ons manager, the version I had was from 2011.

atmab 0 solutions 1 answers

hi, same black screen when attempting to watch a video, ironically the previews all work. also my sound is choppy when opening/closing pages. same prob on 3 non networked but common internet computers. reset firefox, reinstalled firefox, uninstalled flash, reinstalled, same with java, installed flash-x, and previous versions. something about real player caught my eye, i had started to install real player a week or so ago, cancelled & uninstalled it. not in my program files or shared pgm files. BUT there were still 120 registry entries for real player, networks, etc; real had assigned itself default player for every media extension and some i never heard of. when downloading media players i watch for this and even if let's say a player makes itself default--it's noticable & pretty easy to fix right in player preferences. what was weird was real player did NOT show as default in my file extensions or autoplay, nor did it show up when right clicking "play with". also my preferences from ie are NOT copied in firefox. not feeling like searching thru and deleting registry keys, and windows rstrui didn't help; so i restored the partition from a 14 day old backup (acronis, macrium work well for me). this worked fine for the 1 computer, but i wanted to try changing media defaults manually and i installed realplayer completely & uninstalled it and that did the trick. so long story short for my problem was even if everything shows the right flash plug-in and default player, don't believe it! i love firefox to the nth degree over ie but this is one that i can't blame the microsoft people on, nor the mozilla folks---and for once it WASN'T a flash player update either---but realplayer wasn't anywhere in my pgm or local settings, or user or file extensions--but it was an autorun-no service attached but also in task scheduler and did find it's way into my realtek soundmgr files. arrggh.  ;-)

Gail4Peace 0 solutions 1 answers

I just did a system restore, and now all is well. (took it back 30 days).

Videos worked fine, but had the s.ytimg.com pop-up blocking the video unless I agreed to let it store information on my system. Research showed that this is indeed an Adobe thing, and that you can block it, but it may interfere with your being able to play games or store your YouTube history on the computer. If you "right click" on the box and allow it to always store information on your computer, it will go away.

Relief! I've been hours trying everything that everyone mentions. I even wonder if videos weren't playing because I had blocked programs from storing information on my computer.

Will someone try that? (Security settiings)

ZeeX10 0 solutions 2 answers

I tried some solutions recommended like uninstall flash and reinstall a new copy, delete cache and cookies and nothing worked. Then I saw it could be adblock, so I disabled adblock from addons manager and did a ctrl+F5 and voila a Victorias Secret ad popped up(don't mind seeing those kinds of ads heh) then after skipping the ad the video began playing. I reenabled ABP and clicked on another video and it started playing.

Only other thing I did was disable hardware acceleration in FF, but didn't do a browser restart or anything like that so I doubt that was the problem. Just throwing that out there just in case.