X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox crashes when going on Facebook.

Posted

I use Firefox on a Mac (Snow Leopard) and I recently updated Firefox to version 18.0. After I updated, Firefox will freeze everytime I go on Facebook and I would have to force quit it. One thing I noticed is that it crashes when almost everything is loaded but the chat. Does anyone know how to fix this?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
415 solutions 4920 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem. _________________________________________________________________________________

We're sorry to hear that your Firefox seems to be crashing. Please perform the following steps to give us a crash report ID that helps us find out more about the cause of the crash.

  1. Enter about:crashes in the Firefox location bar (that's where you enter your website names) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the most recent 5 report IDs that you see in the crash report window and paste them into your forum response.

Thanks in advance for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

LadyDarkStar 0 solutions 2 answers

Hi,

I am having the same problem. Firefox updated earlier today to 18.0 and since then it keeps freezing when I visit Facebook and I have to force quit it. I'm running Snow Leopard (10.6.8).

I tried starting Firefox in safe mode, and disabling all add-ons. I even went to "Troubleshooting Information" and reset Firefox to fix this problem, and nothing works.

Maybe the problem is with compatibility between Snow Leopard and the new update. I hope there is a fix to that soon.

cake4all 0 solutions 1 answers

Helpful Reply

I have this same problem and I'm running Mountain Lion 10.8.2. Facebook seems to work fine if I navigate to someone's page directly, but freezes firefox if I try to go to the news feed. As with the other posters, I've tried starting firefox in safe mode but it has no effect.

This issue seems exactly the same as the one posted here about Firefox 17: http://support.mozilla.org/en-US/questions/945235

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

If you go to about:crashes, can you give me the crash IDs? (they start with bp-). We are investigating a crash on Facebook, and this might be it.

TheHippyWitch 0 solutions 6 answers

I have been having the same problem since updating to 18.0, and I am also using Snow Leopard (10.6.8). Here are my most recent crash reports, all of which I can trace to Facebook. However, I did not submit them all as that gets tedious.

F6382B06-E155-4233-87ED-E9C4A42900AB 89898EAB-B52F-40E0-ACC1-C2ADC6D17B0B 489AD007-4FD3-4D52-82DF-A4E50BAD473F 21012461-ACE3-4580-9EFF-47B39F5B73C3 04274618-7C67-460B-8883-58E3F672353E 82261456-CE2F-4A39-9C74-AEFDCD4F39DE D36EFDCB-F1F3-4B54-B6A9-7BC394A9A548

(I think the last one listed is the one I actually submitted.)

TheHippyWitch 0 solutions 6 answers

Or maybe these are the right numbers? They changed when I clicked on them (and hopefully the returns will carry in this post).

bp-495366d3-4abd-45ba-8ac6-5c6c32130112

bp-df5756df-51c3-465b-8326-d80eb2130112

bp-657af657-27d7-4c3b-9d3c-edd692130112

bp-cf98f07a-7ccb-47d1-9b27-0ce4f2130112

bp-1864a467-0916-40ed-800f-e65ef2130112

bp-200b08c3-3f65-4e36-835d-36e842130112

bp-53c44f55-cf6c-4922-a487-f1c8c2130112

bp-9210e07e-935a-4a4b-9766-c9ff12130112

bp-7c4e470f-ba47-473e-9d68-072872130112

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Looks like a problem with one of the plugins.

numberninemac 0 solutions 1 answers

Solution for this problem is as follows:

Step 1: Go to about:config

Step 2: Click on "I'll be careful, I promise" when it tells you this might void your warranty.

Step 3: In the search box, type "dom.max_script_run_time"

Step 4: Double click "dom.max_script_run_time" and change the value from 10 to 25

That should fix the problem.

LadyDarkStar 0 solutions 2 answers

I think the problem is with one (or many) of the plug-ins.

bp-2e321190-7aaf-4083-b98a-72b962130113 bp-3e850713-1769-47bc-b85c-9028e2130113 bp-f3aee8d8-99d9-4ac6-aec3-1abb32130113 bp-c8e9c580-e5ef-45cf-af54-9c62f2130113 bp-6667605a-e123-4a5d-a8c1-7b76f2130113

Sporin 0 solutions 3 answers

I have this same problem, just gets stuck "running ball" in the News Feed. I have to Force Quit to resolve. It doesn't happen on individual pages.

I've tried the "dom.max_script_run_time" value change and no difference. Also does it when running in safe mode.

I came back to Firefox 6 months ago from Chrome, but this issue is a near-deal-breaker for me as I am on Facebook all the time for both personal use, and managing Client pages.

OSX 10.8.2, Firefox 18

1085CB31-C9F9-4E85-91F1-AF1720A6E5B81/14/136:31 AM1FA838BA-AE66-4024-A0F5-A8EBE7896DC91/14/136:30 AM60900783-447E-46AA-A4A1-1CD3D8FC0E581/14/136:30 AM8A7A80AE-19B2-4627-AF46-AD400E34FA211/14/136:29 AM0E96596E-0C54-415A-9CD2-AFF3A6462CB51/14/136:28 AM1694A3D9-1FD3-4B02-A190-39C397DCC22D1/14/136:27 AMA845B0E6-E704-42F1-AB12-758F369A64391/14/136:25 AM69E3523C-34E0-4846-8B4C-F1688DBF83F31/14/136:18 AM5ECD2F8F-BC36-4ACB-9A47-D84449960B7A

TheHippyWitch 0 solutions 6 answers

I have repeatedly tried disabling all my plugins (which gets Facebook to load) and then enabling them one by one. I check Facebook after each one is enabled, and it still works. Even after all ten plugins are reloaded. Then I will leave the comp for some time, come back and restart Firefox... and there is the whirly ball of doom again. Here are my most recent crash reports:

53B5DCFC-C3CE-4DEF-AF27-C270821A16B2 1/14/134:34 PM (bp-c5df4531-9def-4bf0-bcf2-e8ec52130115 after I click on it)

B0DFF788-8BDC-4852-99B4-D14B1190C843 1/14/134:23 PM (bp-4357c544-82e6-4478-a242-dceb02130115 after I click on it)

Also, here are a list of my plugins, maybe we can narrow down the offending plugin somehow?

Silverlight Plug-In

QuickTime Plug-in 7.6.6

Java Applet Plug-in

Shockwave Flash

iPhotoPhotocast

Google Earth Plug-in

Microsoft Office Live Plug-in

AmazonMP3DownloaderPlugin

Adobe Acrobat NPAPI Plug-in, Version 10.1.3

Unity Player

TheHippyWitch 0 solutions 6 answers

And now it is happening on Kongregate.com, when I tried to play a Unity game. So that makes me think Unity is the problem. Anyone else have other sites causing the same issue?

20F50F6E-64AB-4338-BF0A-FECB5F219157 1/14/137:35 PM

0DD24D2B-AFB4-4FAD-8733-E46C659713EA 1/14/137:34 PM

TheHippyWitch 0 solutions 6 answers

And the dom.max_script_run_time fix helped nothing.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

Can you install Firefox nightly and tell me if Unity still crashes? http://nightly.mozilla.org/ it should be fixed there.

TheHippyWitch 0 solutions 6 answers

Seemed to work fine, though I found out another user on my computer was able to get it to work last night by removing and reinstalling Unity. Haven't had the crash issue yet today, as it seems to come and go.

Modified by TheHippyWitch

Question owner

Somehow I made a duplicate of this question. Heres the other forum: https://support.mozilla.org/en-US/questions/946538?page=2#answer-399103

iH85CH001 0 solutions 4 answers

Ok... I found a temporarily fix... go to facebook.com, then click the (X) button in the bar to make the page stop loading. it should only be half loaded... if firefox locks up, you waited too long. Click on your name in the corner. Then when that loads, click home, next to your name!!!!! There is your news feed! Hope this works... It worked for me. Enjoy!!!

Sporin 0 solutions 3 answers

The latest Firefox update (which I got today) seems to have cured this. Thank you Mozilla!