X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't save non http bookmarks in firefox

Posted

Can't save non http bookmarks in firefox

Amongst standard website favourites saved on my IE toolbar i have several html documents/pages of my own making. These obviously begin with a non-http address.

Examples are pages that contain an array of favourite webcams on a single page, or a page that opens up several related sports sites each in their own tab, or a stormchasing swathe of tabbed windows covering live video chase, weather radar, emergency service scanners etc. etc.

An address would take the format on the lines of "C:\Documents and Settings\USERNAME\My Documents\Football Results and Tables\UK.html"

Firefox insists on adding 'http' before the C:\ (plus unlike IE it also adds the %20 for spaces.)

Can anyone help to to get FF to accept a favourite that is not a website.

Chosen solution

It's ok i've just solved it myself, also dispenses with the need to type in %20 for every space.

One needs to add ahead of C: the following

file:\\\

So a sample address would be

file:\\\C:\Documents and Settings\USERNAME\My Documents\Football Results and Tables\UK.html

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Media Center PC 3.0; .NET CLR 1.0.3705; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET4.0E; .NET CLR 3.5.30729; .NET4.0C; .NET CLR 3.0.4506.2152)

More Information

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24389 answers

I just verified that it still works for me in Firefox 18.0, using the "star" in the Location Bar.

Try the Firefox SafeMode to see how it works there.
A troubleshooting mode, which disables most Add-ons.
Troubleshoot Firefox issues using Firefox SafeMode

When in Safe Mode...

  • The status of plug-ins is not affected.
  • Custom preferences are not affected.
  • All extensions are disabled.
  • The default theme is used, without a persona.
  • userChrome.css and userContent.css are ignored.
  • The default toolbar layout is used.
  • The JIT Javascript compiler is disabled.
  • Hardware acceleration is disabled.


  • You can open the Firefox 15.0+ SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.


To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.


If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

When you figure out what is causing that, please let us know. It might help other user's who have that problem.

Chosen Solution

It's ok i've just solved it myself, also dispenses with the need to type in %20 for every space.

One needs to add ahead of C: the following

file:\\\

So a sample address would be

file:\\\C:\Documents and Settings\USERNAME\My Documents\Football Results and Tables\UK.html