X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

BiblicalTraining.org tells me my brower doesn't support their video, & I just downloaded FireFox. What Now?

Posted

Lecture 1 BiblicalTraining.org tells me my brower doesn't support their video, & I just downloaded FireFox. I've done what checking I think can be done; an email to BiblicalTraining responds that Firefox works.

Additional System Details

Installed Plug-ins

BiblicalTraining.org tells me my brower doesn't support their video, & I just downloaded FireFox. I've done what checking I think can be done; an email to BiblicalTraining responds that Firefox works.

Application

  • User Agent: Mozilla/4.0 (compatible; MSIE 7.0; AOL 9.7; AOLBuild 4343.19; Windows NT 5.1; Trident/4.0; SearchToolbar 1.2; GTB7.4; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322; .NET4.0C; BRI/2; McAfee; yie8)

More Information

BiblicalTraining.org tells me my brower doesn't support their video, & I just downloaded FireFox. I've done what checking I think can be done; an email to BiblicalTraining responds that Firefox works.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

Do you have to logged on to that site to access that page?

Can you post a link to a publicly accessible page that doesn't require authentication (log in) to access it?

You didn't list your plugins, so I can't tell if you are missing some commonly used plugins.