X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Add-ons manager is slow

Posted

Opening the Add-ons manager windows freezes Firefox (started with v. 17) and takes 15-30 seconds to completely load and unfreeze.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • HP Product Detection Plugin
  • HP Active Check Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • HP Pit Plugin
  • VLC media player Web Plugin 2.0.2
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Foxit Reader Plug-In For Firefox and Netscape
  • A component of your photo software powered by RocketLife
  • 5.1.10411.0
  • 3DVIA player(5.0.0.15). For more information, visit the 3DVIA player web site.
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • NPWLPG
  • Cooliris embedded in a tab
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Google Gadget Plugin 5.7.712.19360
  • np-mswmp
  • Allows browsing on RealArcade sites with Mozilla browsers.

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

John Karahalis 3 solutions 66 answers

How many add-ons do you have installed?

Question owner

Seventy-seven enable and twenty-seven disabled. The number was not an issue prior to FF17.

John Karahalis 3 solutions 66 answers

Thanks for that information.

Some add-ons interfere with the Add-on Manager itself, causing it to open very slowly or not at all.

Can you please try opening Firefox in safe mode and then trying to open the Add-on Manager again? My bet is that the Add-on Manager will open quickly when you do this.

If the Add-on Manager does open quickly in safe mode, you might want to return to normal mode and then disable add-ons one-by-one until you find the culprit. If you have AutoPager or Tab Mix Plus, try those first, as they have been known to cause this problem in the past.

Question owner

Thanks -- I'll give it a try and let you (and others) know the results.