X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

locks and have to restart computer

Posted

Hi I'm having trouble whereby firefox seems to stop responding. I have not noticed it with any particular websites, just seems to be random e.g. ebay, first direct banking. I can only shut it down using the task manager and then firefox will not restart. can only get it to restart by restarting my whole computer. i am on version 17.0.1.

Any reasons why this is happening?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Yahoo Application State Plugin version 1.0.0.7
  • 5.1.10411.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Yahoo! activeX Plug-in Bridge
  • Windows Multimedia Services DRM Store Plug-In
  • Intel Indeo® video 5.1 PD Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8043 answers

Hi,
sorry you are having problems.

Malware is one possibility, or conversely multiple security related applications interfering with one another. The other likely problem is with some software extension you have.The final symptom of not being able to close down and restart is a hang on exit.

  1. What security related software do you have installed ?
    • you may need to investigate whether malware is a problem, but lets skip that for now. You may wish to avoid any internet banking with Firefox on the current machine until this is sorted out. (N.B. IF it is a malware problem it may also affect alternative browsers )
  2. Try in safe mode (but NOT at this stage using reset). Safe mode is available by using the Firefox button options see Troubleshoot Firefox issues using Safe Mode
  3. Try in safemode, and disable all plugins Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

Please Post back with what you have tried and how you geton.

The next stages would be to

  1. carefully consider possible reasons for hangs firefox-hangs-when-you-quit-it
  2. try a firefox reset (you loose some info)
  3. investigate potential malware problems (far from straightforward)

I can provide further information and links, but lets try first things and see what happens.

Question owner

John

Thanks for your reply. In answer to some of the questions:

1. I am using Avast antivirus (the free version). don't know if of any relevance but also have Adblock Plus and Rapport running.

2. Will try like this and revert.

3. Will try and revert.

One thing I have notices (and again not sure if relevant). When going on things like ebay, first direct etc the machine seems to be running a lot faster (and noisier) to get what it wants to get done.

Thanks

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8043 answers

You may have updated to Firefox18 since your first message. Note that may then require your AV & Rapport to be updated. Rapport in particular tends to cause problems initially with new releases of Firefox. I doubt the combination of Avast Adblock and Rapport will itself cause any problems.

One thing I have notices (and again not sure if relevant). When going on things like ebay, first direct etc the machine seems to be running a lot faster (and noisier) to get what it wants to get done. 

Not sure what could cause that, but one possibility is that IF you did upgrade to Firefox18, then that has a change to the way it deals with JavaScript, that is expected to speed things up (see).


edit, additional information
Note the Java script compiler may be turned off by changing a preference. That may be useful in troubleshooting problems suspected to relate to javascript.

In about:config toggle javascript.options.methodjit to false. (see)

Modified by John99