X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox is assuming all hyperlinks are relative when they are absolute.

Posted

ie follows links on intranet pages just fine, but firefox is modifying the links with the page address and thus breaking them.

Additional System Details

Installed Plug-ins

  • Pando Web Plugin
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Microsoft Lync 2010 Meeting Join Plug-in
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Application Basics
Name
Firefox
Version
17.0.1
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Multi Links
3.0.0.19
true
multilinks@plugin
Adobe Acrobat - Create PDF
1.2
false
web2pdfextension@web2pdf.adobedotcom
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20121128204232
browser.startup.homepage_override.mstone
17.0.1
extensions.lastAppVersion
17.0.1
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
104858
plugin.disable_full_page_plugin_for_types
application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce GTX 560
Vendor ID
0x10de
Device ID
0x1201
Adapter RAM
1023
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
9.18.13.623
Driver Date
8-30-2012
Adapter Description (GPU #2)
Intel(R) HD Graphics
Vendor ID (GPU #2)
0x8086
Device ID (GPU #2)
0x0102
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Driver Version (GPU #2)
8.15.10.2696
Driver Date (GPU #2)
3-19-2012
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
GPU Accelerated Windows
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

John Karahalis 3 solutions 66 answers

Hey tfortier. My hunch is that this is an issue with the website you are using.

Can you please share a web page that contains links that do not work correctly? Does the same thing happen in other browsers like Internet Explorer?

Question owner

Sorry, its an intranet site. IE works fine. This is the first time I've hit the site with Fox in a couple of years, it seems to me it worked ok once apon a time... But the fresh install sees all links as being realative (on the intranet). Even if I modify the code to include "FILE:" it still puts in extra "/" that breaks the link.

John Karahalis 3 solutions 66 answers

It seems that the site is incorrectly assuming that you use Internet Explorer. The site probably does not work in Chrome either. If this is true, it is technically a bug in the site itself. I recommend that you contact the owner of the site about this.

Anyway, I think you can still get the site to work in Firefox despite the bug. Install Local Filesystem Links and try using those links again.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

There seem to be backslashes in the links as you can see in the pop-up that show the URL on hover.

Firefox needs forward slashes and doesn't convert them automatically like IE does.

You can try this version of Slashy that I've modified to work in more cases.