X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

It’s so weird I can’t turn off safe search for Google in new version of Firefox?

Posted

I was able to turn off the Google safe search in old version but in new version I can’t. I tried IE and I can turn off safe search. I don’t know what is wrong and it’s so weird. When I go to the page of safe search setting it shows and says (Turn on safesearch to filter sexually explicit content from your search results.) but the safe search is on already. Please somebody say something I am driving out of my mind. And the stupid thing is that I have to use IE for searching and use Firefox for other stuffs.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Are you talking about the SafeSearch filters on the Google Search settings page?

Such details are stored in a cookie, so make sure that you keep such a cookie.

  • Create an allow cookie exception (Tools > Options > Privacy > Cookies: Exceptions) to keep such a cookie, especially for secure websites and if cookies expire when Firefox is closed.

Make sure that you do not run Firefox in Private Browsing mode.

Try to clear the cache and the cookies from sites that cause problems if saving that choice isn't working.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

You can also check for problems caused by extensions.

Question owner

Hi Cor-el. Forget about the cookies. I must remind you that when I go to the safe search setting (the first link you added on post) it tells me Turn on the safe search that means the only activating button is that to turn on the safe search when the safe search is already on. I think you get it wrong. Maybe you thought my problem is when I click the turn off button it doesn’t work but it’s not. there is only a turn on link and it is only in my new Firefox I tried that in IE and it’s fine. I think this is a serious problem.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

Do you see the check box to turn on "√ Filter explicit results" ?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Helpful Reply

Yes and it’s exactly the same screenshot you posted.

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97024 answers

So, nothing happens if you click that check box to toggle this setting?

Question owner

The check box is not checked but the moderate safe search is on and if you must know that the check box (filter explicit result) will turn on the Strict safe search and deactivating that only turn off the strict safe search mode but there is no way to turn off the safe search mode.

Mahasona 0 solutions 2 answers

Helpful Reply

The problem is not Firefox - it's Google. They have changed the safesearch options.

The way round it is to add the word 'nude' or similar to your keywords. Then you'll get taken to an 'are you sure' type option before finally showing you your results.

More on these websites:

http://thenextweb.com/google/2012/12/12/google-changes-search-image-safesearch-explicit/

http://www.webpronews.com/google-preventing-u-s-users-from-disabling-safesearch-2012-12

Question owner

Sorry to answer to late because I thought nobody will ever answer again so I didn’t check the post. The serious problem is about the image search engine because I don’t have the safe search option when I am searching the web the safe search option I mean the drop down list at the top right of the page only shows when I am in the image search engine. First I thought I need to sign in to my Gmail but that doesn’t work to. Searching the web has no problem but the image search engine has the problem. And something isn’t right about your post. As I hope you read my other post I said it is like that only in Firefox and in the others like IE is fine that’s why I am confused. Updating the Firefox gave me so many new abilities but since I update it I found so many problems. I can handle it but giving some knowledge makes me happy.

Mahasona 0 solutions 2 answers

I DID check with IE before posting my reply to you with the same result as Firefox ( no 'safesearch off').

However, I've just checked again and all is ok with both browsers. Google must have fixed whatever it was they were doing.

Modified by Mahasona