X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Top bottom page hotkeys not working properly

Posted

I have noticed this for quite some time now, but the "top of page" (Home) and "bottom of page" (End) hotkeys don't work properly anymore.

Sometimes it works as expected.

Sometimes, it only change the line the cursor is pointing to (despite not being in a modifiable area), and I need to use Ctrl+Home / Ctrl+End to make it works (ie: the official firefox hotkeys help page)

Sometimes, none of this works (on forums most of the times).

Is there some settings to make it work like old firefox (as I said, that issue is going on for quite some time now so I don't know which version was working correctly)

Chosen solution

You may have switched on caret browsing.

You can press press F7 (on Mac: fn + F7) to toggle caret browsing on/off.

  • Tools > Options > Advanced : General: Accessibility: [ ] "Always use the cursor keys to navigate within pages"

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • Amazon MP3 Downloader Plugin 1.0.17
  • Next Generation Java Plug-in 1.6.0_35 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Chosen Solution

You may have switched on caret browsing.

You can press press F7 (on Mac: fn + F7) to toggle caret browsing on/off.

  • Tools > Options > Advanced : General: Accessibility: [ ] "Always use the cursor keys to navigate within pages"

Question owner

Thank you, I didn't know about that feature, and disabling it fixed my issue.