X
Tap here to go to the mobile version of the site.

Support Forum

Fonts on certain websites appear boldfaced when they shouldn't, is there a fix?

Posted

Since about mid-November I've noticed some websites' fonts are boldfaced where they weren't before. I have tried other computers and found the same websites' fonts normal. I've been able to create a list of websites where this has taken effect:

-Google

-Yahoo

-Wikipedia

-YouTube

-TVTropes

-Wikia

-Possibly others, although I haven't found them yet.

I didn't notice it before the fonts were changed on my computer, but I suspect all those sites use the same default font. Although it would be possible to restore them by forcing my custom font settings, I'd prefer to keep that as a last resort.

A similar problem was apparently reported here: https://support.mozilla.org/en-US/questions/942466#answer-385848. Since it was reported at about the same time as I noticed the same thing, this could be the same problem, although I use a different version of Firefox (14.0.1).

This has been going on for almost two months, and I'd appreciate any advice to fix the problem. Thanks in advance.

Since about mid-November I've noticed some websites' fonts are boldfaced where they weren't before. I have tried other computers and found the same websites' fonts normal. I've been able to create a list of websites where this has taken effect: -Google -Yahoo -Wikipedia -YouTube -TVTropes -Wikia -Possibly others, although I haven't found them yet. I didn't notice it before the fonts were changed on my computer, but I suspect all those sites use the same default font. Although it would be possible to restore them by forcing my custom font settings, I'd prefer to keep that as a last resort. A similar problem was apparently reported here: https://support.mozilla.org/en-US/questions/942466#answer-385848. Since it was reported at about the same time as I noticed the same thing, this could be the same problem, although I use a different version of Firefox (14.0.1). This has been going on for almost two months, and I'd appreciate any advice to fix the problem. Thanks in advance.

Modified by hkzeppelin

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Musicnotes Viewer plugin 1.19.0 For more information visit www.musicnotes.com
  • ScorchPlugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1196 solutions 7853 answers

First, you need to update to Firefox 17.0.1 Update Firefox to the latest version

Then try the steps listed at Websites look wrong or appear differently than they should

First, you need to update to Firefox 17.0.1 [[Update Firefox to the latest version]] Then try the steps listed at [[Websites look wrong or appear differently than they should]]

Modified by Tyler Downer

SilentResident 0 solutions 4 answers

Helpful Reply

Hey! I had exactly the same issue as you! Do you have an addon called WebSecurityKeeper installed into your Firefox, without your permission? Check your Addons list pls. I had this addon and when I uninstalled it, my fonts in Firefox returned to normal.

Its possibly a malicious addon. But I am not sure. I have no idea how it got installed my computer.

Hey! I had exactly the same issue as you! Do you have an addon called WebSecurityKeeper installed into your Firefox, without your permission? Check your Addons list pls. I had this addon and when I uninstalled it, my fonts in Firefox returned to normal. Its possibly a malicious addon. But I am not sure. I have no idea how it got installed my computer.
cor-el
  • Top 10 Contributor
  • Moderator
12140 solutions 112771 answers

Try to disable hardware acceleration in Firefox.

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

Try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://hacks.mozilla.org/2010/09/hardware-acceleration/ Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled. *http://kb.mozillazine.org/about:config

Question owner

Well, I tried everything listed above, and nothing worked. The addon listed by SilentResident didn't show up in my list, and disabling hardware acceleration didn't work either. I updated to the latest version of Firefox... again, nothing was changed.

HOWEVER, I tried opening Firefox in Safe Mode, and the fonts on the websites I mentioned went back to normal. I noticed that, under the "appearance" tab, the default theme was disabled. After exiting Safe Mode, I disabled all addons except the theme, and the fonts were still boldfaced. As a result, I believe the problem may be with the theme itself. Is there any way to disable it by itself?

Well, I tried everything listed above, and nothing worked. The addon listed by SilentResident didn't show up in my list, and disabling hardware acceleration didn't work either. I updated to the latest version of Firefox... again, nothing was changed. HOWEVER, I tried opening Firefox in Safe Mode, and the fonts on the websites I mentioned went back to normal. I noticed that, under the "appearance" tab, the default theme was disabled. After exiting Safe Mode, I disabled all addons except the theme, and the fonts were still boldfaced. As a result, I believe the problem may be with the theme itself. Is there any way to disable it by itself?
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1196 solutions 7853 answers

This is most lilely Hardware Acceleration. try to update your Graphics driver. Search for and install new graphics drivers

If that doesn't work, Disable Hardware acceleration. Turning off hardware acceleration

This is most lilely Hardware Acceleration. try to update your Graphics driver. [[Upgrade your graphics drivers to use hardware acceleration and WebGL#w_search-for-and-install-new-graphics-drivers|Search for and install new graphics drivers]] If that doesn't work, Disable Hardware acceleration. [[Upgrade your graphics drivers to use hardware acceleration and WebGL#w_turning-off-hardware-acceleration|Turning off hardware acceleration]]
SilentResident 0 solutions 4 answers

Funny enough, I had once again this problem at past. The only solution for me was to create a new Firefox Profile and switch to it. This fixed all the text font issues. Strange, but it did.

Funny enough, I had once again this problem at past. The only solution for me was to create a new Firefox Profile and switch to it. This fixed all the text font issues. Strange, but it did.
cor-el
  • Top 10 Contributor
  • Moderator
12140 solutions 112771 answers

Helpful Reply

You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection).

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection). *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/ You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and temporarily disable website fonts to test the selected default font. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"

Question owner

Okay, I've been able to identify that the websites in question are using Arial Bold. I can't tell, though, if this was the case before, can someone run a quick check to see if the sites are using the Bold font?

Okay, I've been able to identify that the websites in question are using Arial Bold. I can't tell, though, if this was the case before, can someone run a quick check to see if the sites are using the Bold font?