X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Since upgrading Firefox I get several problems - Adobe Flash crashes, maps/calendars display odd characters, sites don't display etc.?

Posted

Adobe Flash crashes frequently, pretty much daily; Maps and calendars display black diamonds, question marks etc. Some sites display as bullet point link lists; Some sites show overlapping text and action buttons don't work, eg. can enter log in credentials but nothing happens; Ticketmaster security check does not display distorted text. Etc...

All the above work fine in the IE browser.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Shockwave Flash 11.3 r300
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6642 answers

First, update to Firefox 17.0.1. Update Firefox to the latest version

Then update your plugins: https://www.mozilla.org/plugincheck/

Then read Websites look wrong or appear differently than they should

Question owner

Updated Firefox version and add ins but made no difference.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


You can check the network.http.* prefs on the about:config page.

Reset network.http prefs to the default value via the right-click context menu -> Reset if they are user set (bold).

Check at least:


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Resetting network.http.accept-encoding to the default values seems to have sorted the website display problems. Not sure about the adobe crashes though.

justlou 0 solutions 15 answers

When I updated to FF 17, I had similar issues as you, especially with Flash. A Google search showed MANY people having the same problems with FF 17. I downgraded to FF 16, and all has been well now for about 2 weeks.

Question owner

I am dubious about moving back to a previous version as this has caused me lots of problems previously, admittedly in the IE browser.

Without having done anything obvious to me the web pages have just started playing up again and checking the config file I find the network.http.accept-encoding is no longer set to the default! Any ideas what is doing this.

Thanks.

wramshaw 0 solutions 2 answers

OK it is time to get this fixed. I have had this problem since Adobe 11.3 and Firefox (I think) 14 or 15. Running Windows Vista. Hate IE. However this is pushing me rapidly towards Chrome. Very tired of reading Adobe's posts that they have fixed it. Also growing tired of reading Firefox posts about fixes that simply do not work. Installed. Reinstalled. Used program clean up programs to remove registry entries. Nothing works.

Question owner

I now have a new laptop and have installed Firefox (18.0.2) and Adobe Flash Player (11.5) and the problem seems to have cleared though who knows why?

wramshaw 0 solutions 2 answers

OK I am done with Firefox. Downloaded Firefox 19 and the problem still exists. Moving on to Chrome. I have completely lost faith in both Adobe and Firefox.