X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the new feature that disables outdated plugins unless they are clicked?

Posted

I'm running Adobe Acrobat 8. I'm happy with it. Firefox has a new feature that automatically disables the PDF plugin unless it's clicked. It's called the "Click to Play" feature. Even when disabled, it's not really disabled: it activates itself for "vulnerable plugins." Though there is an option to make a website trusted for plugins, there is seemingly no way to make the PLUGIN ITSELF trusted. As a result, every time I get a PDF, I have to Click to Play.

Question: How do I truly disable this stupid new feature?

There is the following support article that explains this new system, and that the only solution is trust a website, but apparently can't disable the feature or trust the plugin:

http://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins?esab=a&s=disable+click+to+play&r=13&as=s

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.1.10329.0
  • Adobe PDF Plug-In For Firefox and Netscape 8.3.1
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 1.9.0042.0
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

The best solution is to update Adobe Reader to version 11. Adobe 8 is VERY out of date, and vulnerable t lots of critical security holes (Infected PDF's are one of the most common ways a virus get's spread on the web). If you update, then you won't have to see that message again. I know it will take a few minutes of work now, but that's better than days or work and money when (not if, when) you get infected because of an older PDF reader.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

(note that this is not about the Adobe Reader, but the Adobe Acrobat 8 program)

Question owner

So, if I want to keep using my Acrobat 8 Pro without this reminder every single time I open a PDF, I have to either return to a version of Firefox from a month ago that didn't have this feature, or switch to Chrome? There's really no way to disable this new Firefox feature? This mandatory Click to Play thing is something I'd expect from IE, not Firefox. It reminds me of the Mac vs PC commercial (and I love PCs) where Vista's bodyguard, mimicking User Access Control, says: "You are coming to a sad realization: cancel or allow." Only, in this case, it can't even be turned off. It's the Firefox goon. I'll give it a couple of weeks; I'm sure the Mozilla team will come through and allow this thing to be disabled.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Can't you enable that plugin permanently on the Tools > Add-ons > Plugins page?

the-edmeister
  • Top 10 Contributor
  • Moderator
3197 solutions 24401 answers

Click to Play has nothing to do with Firefox disabling plugins due to the plugin being out of date. As corel mentioned, enable the plugin in Addons > Plugins and it will stay enabled.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins We have CTP blocklisting now

danhash 0 solutions 3 answers

The question was still not answered. How can the click-to-play "feature" be 100% disabled? No more lectures about security risks are needed as everyone here understands that this is inadvisable. The original poster, myself, and every other person asking this question that has been ignored so far just want an answer, free of the high and mighty "omg security risk!" attitude.

philipp
  • Top 10 Contributor
  • Moderator
2045 solutions 8900 answers

disable the outdated adobe pro pdf plugin in firefox > addons > plugins & install the current adobe reader in order to view pdfs embedded in the browser safely & without click-to-play interfering or use the pdf viewer addon: https://addons.mozilla.org/firefox/addon/pdfjs

danhash 0 solutions 3 answers

Helpful Reply

Your comment is useless.

The question is how to disable click-to-run, not how to disable out of date plugins. You obviously have not read the thread, my post, or the original posters post.

How can you disable click to run? The question will keep being asked until it is answered.

philipp
  • Top 10 Contributor
  • Moderator
2045 solutions 8900 answers

well, even that's not the answer you want to hear, it's not possible to selectively switch off ctp for outdated plugins. you can only disable the blocklisting functionality in firefox altogether which will have further repercussions though & remove the protection from malicious extensions and graphics drivers which are known to crash the browser...

i can only assume that the reason to switch off click-to-play in this case is for convenience purposes - and since the OP stated that he is having the issue with adobe 8 pro it is very easy to circumvent by installing a up-to-date reader version next to the old acrobat pro & letting it to the job of displaying pdfs inside the browser.

outdated plugins are the #1 infection vector on the web nowadays & in this case you should definitely make security a higher priority than convenience.

danhash 0 solutions 3 answers

I have never gotten infected from web browsing. Besides, if I was really worried about viruses, etc. I wouldn't be using Windows. I'm not asking about selectively switching off CTP for outdated plugins. I'm asking about switching off CTP *ENTIRELY*. I think it's a stupid system, but I know it was put in place with good intentions. I'm not trying to have a debate about CTP. It's a pretty simple question really; how can I turn it off? What you or anybody else thinks about CTP is 100% irrelevant and beside the point. How can it be turned off completely?

Surely there is a way to turn off the CTP function without completely disabling blacklisting. If there isn't, then that's crazy, but I still want to turn of CTP whatever it takes. Like I said I've never had my browser or my PC infected from web browsing with Firefox and I'd rather have any and all security "features" turned off if they massively interfere with the usability of the web browser.

philipp
  • Top 10 Contributor
  • Moderator
2045 solutions 8900 answers

there is no way to turn off ctp for outdated plugins at the moment - the only option regarding ctp in about:config (plugins.click_to_play) let's you turn it on for all other plugins too, but you obviously wouldn't want that. the future default setting in firefox will be that all plugin content, except the current version of adobe flash player, will only be executed on a per demand basis btw...

Question owner

I'd better buy some Google shares. I predict an exodus to Chrome.

turls2201 0 solutions 2 answers

So Mozilla is becoming more and more like Microsoft and Apple.....

I have been using firefox since the days of Pheonix and it was fast, small and agile. It has now become its father - everything it was trying not to be.

This is the latest example of many where so called geeks ( and I am one too) decide on what is best for me! Apple do it exactly with their iTunes - controlling and determining what is good for me. I think I am old enough and brave enough to make my own choices and more importantly ACCEPT those choices and consequences!

To have a feature imposed, with no choice is just big brother! I want the facility to be able to permanently accept a plugin and not have to do it every time. THIS IS MY CHOICE. What give you the right to determine what it good for me....If I want to use an old plugin, well let me.

Like others, I think I will exercise my freedom of choice an switch to another browser.....

Ironically in this case Microsoft IE lets me use the plugin :-D

ttgl 0 solutions 1 answers

Helpful Reply

In about:config, set extensions.blocklist.enabled to false

turls2201 0 solutions 2 answers

But that disables all, which I do not want. I just want to accept an individual plugin

navydisposaleer 0 solutions 7 answers

I have the same problem with Adobe Flash player. Firefox is de-activating this plugin because it is out of date. The reason I use this out of date Flash player is that current up to date versions cause my audio and video to be OUT OF SYNC and there's no fixing it. Adobe is aware of this and recommends using the older version

philipp
  • Top 10 Contributor
  • Moderator
2045 solutions 8900 answers

hello navydisposaleer, you can use the latest version of the 10.3 branch of the plugin instead, which has received all security updates and isn't flagged as insecure: http://www.adobe.com/uk/products/flashplayer/distribution3.html

navydisposaleer 0 solutions 7 answers

Unfortunately, trying to install Version 10.3 can't be done. The install feature says it's an outdated version and the newer version must be installed.