X
Tap here to go to the mobile version of the site.

Support Forum

When I use my own Sync Server, the sync setup always say invalid URL

Posted

I follow the instructions on

https://docs.services.mozilla.com/howtos/run-sync.html

and have running my own sync server.

After that I wanted to setup my FF 17.0.1 on gentoo to sync to MY Server but I always get 'Invalid URL'.

I started the tcpdump on the listening port and haven't seen any request on the server.

I have used the following user tester@tester.com and the sync setup-tool told me that this user-id is already used, due to this fact I assume that ff-sync does not ask MY Server.

Please can you help me to solve this issue. Thanks

I follow the instructions on https://docs.services.mozilla.com/howtos/run-sync.html and have running my own sync server. After that I wanted to setup my FF 17.0.1 on gentoo to sync to MY Server but I always get 'Invalid URL'. I started the tcpdump on the listening port and haven't seen any request on the server. I have used the following user tester@tester.com and the sync setup-tool told me that this user-id is already used, due to this fact I assume that ff-sync does not ask MY Server. Please can you help me to solve this issue. Thanks

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Yousef 13 solutions 71 answers

Make sure you have http(s):// at the start of the URL.

Make sure you have http(s):// at the start of the URL.
cor-el
  • Top 10 Contributor
  • Moderator
12273 solutions 113666 answers

Helpful Reply

Did you try to enable sync logging and check that log (about:sync-log) for errors?

Did you try to enable sync logging and check that log (about:sync-log) for errors? *https://philikon.wordpress.com/2011/06/16/aboutsync-log/

Helpful Reply

I have tried:

http://domain.name:port/ http://ip.address:port/ https://domain.name:port/ https://ip.address:port/

none of them works

I have tried: http://domain.name:port/ http://ip.address:port/ https://domain.name:port/ https://ip.address:port/ none of them works

Question owner

There is no sync-log due to the fact that ff does not connect to the server.

I have make a tcpdump on the server on the listening port of the sync server.

There is no sync-log due to the fact that ff does not connect to the server. I have make a tcpdump on the server on the listening port of the sync server.

Question owner

Is there realy no way to tell firefox 17 that I have a own sync server?

Is there realy no way to tell firefox 17 that I have a own sync server?
cor-el
  • Top 10 Contributor
  • Moderator
12273 solutions 113666 answers

Maybe try to contact the devs via IRC.

Maybe try to contact the devs via IRC. *https://wiki.mozilla.org/Services/services-dev
rnewman@mozilla.com 15 solutions 150 answers

Apparently Firefox's internal network layer doesn't like port 6000. Try another port, and I'll file a bug for that.

Apparently Firefox's internal network layer doesn't like port 6000. Try another port, and I'll file a bug for that.
cor-el
  • Top 10 Contributor
  • Moderator
12273 solutions 113666 answers

(Bug 826086 - Handle errors in asyncOpen)

(please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)

(Bug 826086 - Handle errors in asyncOpen) <i>(please do not comment in bug reports: [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html])</i>