X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Suddenly, my keyboard doesn't work with Mozilla Firefox. I reset Firefox, but still the keyboard doesn't work. I'm typing this now from Internet Explorer.

Posted

Any suggestions would be appreciated.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; McAfee)

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96852 answers

It is possible that you have switched the keyboard layout by accident to one that isn't working. Windows remembers the keyboard layout setting per application and you may have changed the keyboard layout by accident via a keyboard shortcut.

  • Make sure that you have the Language bar visible on the Windows Taskbar.
  • You can do that via the right-click context menu of the Taskbar: Toolbars > Language Bar.
  • Check the keyboard language (keyboard layout) setting for the application that has focus via the icon on the Language bar.
  • You need to do that while Firefox has focus because Windows remembers the keyboard layout setting per application.
  • The default keys to rotate the layout is a combination (Ctrl+Shift or Alt+Shift) that can easily be used in Firefox to activate a menu item.
  • To avoid an unintentional switch, assign a specific key sequence (Alt/Ctrl+Shift+number) to select keyboard layouts and remove the key combination to rotate layouts (Alt+Shift or Ctrl+Shift)
  • Control Panel > Regional and Language Options > Keyboards and Languages > Change keyboards > Advanced key settings > Change key sequence

See also:

Question owner

Thank you for the information. I turned the computer off...then on again...and now it works.