X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When I initiate a new tab, a 'Yahoo' search field pops up. How do I get rid of this annoyance...?

Posted

Details are as you've listed them.

Chosen solution

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).


If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • Roblox Launcher Plugin
  • 5.1.10411.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • NDS Player Plugin
  • npPCShow Plugin
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

I've tried control panel remove SW...no help. I removed 'shop on line' add-on...no help.

iamjayakumars
  • Top 10 Contributor
413 solutions 4897 answers

Disable/ Remove Yahoo Toolbar.

In order to uninstall a possibly unwanted extension, please do the following:

  1. From the Firefox window click the Firefox button at the top left and select Add-ons, or, if the Firefox button is not shown, click the Tools menu and click Add-ons.
  2. Once the Add-on Manager has opened in a new tab, click the Extensions button on the left side of the window.
  3. You should now see a list of your installed extensions on the right side together with buttons on the right side of each extension.
  4. To remove an extension from Firefox, simply click the Remove button. You should see a message that informs you about the successful removal of the add-on.
  5. Note that some add-ons require a Firefox restart to be removed completely. To perform a Firefox restart after the add-on removal, click the Restart now link in the message.

You can find further information about uninstalling extensions in the following articles:

Disable or remove Add-ons

Remove a toolbar that has taken over your Firefox search or home page

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Chosen Solution

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).


If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Question owner

'SearchReset' did the trick...thanks...

Question owner

cor-el's recommendation re 'SearchReset' did the trick...