X
Tap here to go to the mobile version of the site.

Support Forum

Secure connection failed in Firefox 17 only, but not firewall issue

Posted

Firefox was working fine until I installed version 17, since when I have been unable to get on the net at all as I always get the message "secure connection failed". I have checked in Bitdefender firewall, which allows all versions of Frefox. I can use the dreaded Internet Explorer no problem. Any ideas? Windows 7 SP1

Firefox was working fine until I installed version 17, since when I have been unable to get on the net at all as I always get the message "secure connection failed". I have checked in Bitdefender firewall, which allows all versions of Frefox. I can use the dreaded Internet Explorer no problem. Any ideas? Windows 7 SP1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Win64; x64; Trident/5.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; Tablet PC 2.0; .NET4.0C; .NET4.0E; .NAP 1.1)

More Information

Message I get:
Secure Connection Failed
An error occurred during a connection to www.google.com.
Cannot communicate securely with peer: no common encryption algorithm(s).
(Error code: ssl_error_no_cypher_overlap)
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

AliceWyman
  • Moderator
194 solutions 2235 answers
[[Troubleshoot the "Secure Connection Failed" error message]]
AliceWyman
  • Moderator
194 solutions 2235 answers

P. S. I checked "More system details" and it shows:


More Information
Message I get:
Secure Connection Failed
An error occurred during a connection to www.google.com.
Cannot communicate securely with peer: no common encryption algorithm(s).
(Error code: ssl_error_no_cypher_overlap)
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the web site owners to inform them of this problem.  Alternatively, use the command found in the help menu to report this broken site.

As mentioned in the Troubleshoot the "Secure Connection Failed" error message article, the "Secure Connection Failed" error is shown if Firefox can't access a secure site (one that starts with https:). If you are getting this error on nonsecure sites such as http://www.google.com then the problem could be an added extension. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

P. S. I checked "More system details" and it shows: ----- More Information Message I get: Secure Connection Failed An error occurred during a connection to www.google.com. Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap) The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the web site owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site. ------- As mentioned in the [[Troubleshoot the "Secure Connection Failed" error message]] article, the "Secure Connection Failed" error is shown if Firefox can't access a secure site (one that starts with https:). If you are getting this error on nonsecure sites such as http://www.google.com then the problem could be an added extension. See [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]

Modified by AliceWyman

cor-el
  • Top 10 Contributor
  • Moderator
12273 solutions 113663 answers

Helpful Reply

Check the SSL settings:

  • Tools > Options > Advanced : Encryption: Protocols

You can check the ssl and tls prefs on the about:config page.

If any ssl or tls pref is bold (user set) then right-click that pref and choose "Reset" to reset the pref to the default value. Paste this regular expression in the Filter bar at the top of the about:config page:

  • /security.*ssl|security.*tls/

See also:

Check the SSL settings: * Tools > Options > Advanced : Encryption: Protocols You can check the <b>ssl</b> and <b>tls</b> prefs on the about:config page. If any ssl or tls pref is bold (user set) then right-click that pref and choose "Reset" to reset the pref to the default value. Paste this regular expression in the Filter bar at the top of the about:config page: *<b>/security.*ssl|security.*tls/</b> See also: *http://kb.mozillazine.org/about:config

Question owner

Thanks. I have now realised this happens with the google search engine but yahoo still works, as does bing. So it may not be a firefox issue after all.

Thanks. I have now realised this happens with the google search engine but yahoo still works, as does bing. So it may not be a firefox issue after all.
AliceWyman
  • Moderator
194 solutions 2235 answers

If you're having problems with Google's secure search from the Firefox about:home page or from https:///www.google.com what about when you search from http://www.google.com ?

For more information on issues with Google's SSL Search see:

http://support.google.com/websearch/bin/answer.py?hl=en&answer=173733
If you're having problems with Google's secure search from the Firefox about:home page or from https:///www.google.com what about when you search from http://www.google.com ? For more information on issues with Google's SSL Search see: http://support.google.com/websearch/bin/answer.py?hl=en&answer=173733
AliceWyman
  • Moderator
194 solutions 2235 answers

P.S. If you're having problems with other secure (https:) websites, check your SSL and TLS settings in Firefox Options -> Advanced / Encryption and on the about:config page, like cor-el suggested.

Ref: Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox (look under the Encryption tab section)

P.S. If you're having problems with other secure (https:) websites, check your SSL and TLS settings in Firefox '''Options''' -> '''Advanced''' / Encryption and on the about:config page, like cor-el suggested. Ref: [[Advanced settings for accessibility, browsing, system defaults, network, updates, and encryption]] (look under the '''[https://support.mozilla.org/kb/advanced-settings-browsing-network-updates-encryption#w_encryption-tab Encryption tab]''' section)

Modified by AliceWyman