X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Home tabs keep changing to Yahoo how do I stop this

Posted

I have a complex home tab set up. It consists of 8 tabs. every day when I re log into my system and start firefox the home tabs are erases and I get Yahoo as my home screen. I re set my browsers tabs to my desired urls and go to options and say use current tabs as home. Every time I do this the next day it happens again. I will add that my home system is a Mac and work system is a PC they are synched. I am running 17.0.1. I am flipping out. How do I stop this problem

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Amazon MP3 Downloader Plugin 1.0.17
  • Facebook Video Calling by Skype
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.0.55
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Musicnotes Viewer plugin 1.18.8 http://www.musicnotes.com
  • iPhoto6
  • Plugin for viewing Sibelius(tm) music scores http://www.sibelius.com

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

I have gon into about:config and reset mstone a few times and it continues to plague me

iamjayakumars
  • Top 10 Contributor
415 solutions 4927 answers

It's user preference probs.
Delete your old profile and create new.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

cor-el
  • Top 10 Contributor
  • Moderator
10752 solutions 96760 answers

Do you mean that the home page setting changes or do tabs not reopen automatically after closing and restarting Firefox?

Note that on a Mac you need to close the application (Firefox > Quit) if you want to preserve open tabs, otherwise you only close the current window and still have the menu bar visible.

Does this still happen if you disable Sync?

If you do not keep changes to settings after a restart then see:


App (pinned) tabs and Tab Groups (Panorama) are stored as part of the session data in the sessionstore.js file in the Firefox profile folder.

In case you are using "Clear history when Firefox closes":


You can check for problems with the sessionstore.js and sessionstore.bak files in the Firefox Profile Folder that store session data.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

Helpful Reply

I mean that my tabs that are set to open when firefox loads (in options or Preferences depending on OS) get wiped out and my only tab that opens is yahoo... it is as if there is an app resetting my preffeneces

penny-farthing 0 solutions 1 answers

Have you recently installed or updated Vuze or TuneUp? I've got a very similar problem ever since I updated Vuze to version 4.8.1.2 and it tried to sneak in an install of TuneUp as well (which I cancelled). FYI I'm on a Mac running OSX 10.6.8, Firefox 12.0 and I'm in Australia.

Somehow the Vuze update/install also changed the default homepage in all my browsers (Firefox, Safari & Chrome) without my knowledge or permission. I've since changed the default to my preferred homepage in all my browsers, but for some reason Firefox is the only one that keeps reverting back to Yahoo. The page it keeps defaulting to is http://au.search.yahoo.com?type=769480&fr=spigot-yhp-ffmac.

You're right in that I think there's some insidious script or app or something that keeps changing it back to Yahoo despite my repeated attempts to set it to my preferred homepage. The fact that it happened to ALL my browsers at the same time means that there's something outside of Firefox that's making the changes. I've had to stop using Firefox in the meantime until I can find a way of getting it to stop, its just too annoying... and creepy :(

Question owner

Thanks for that bit.. I think Mozilla fixed the problem because it is not doing it anymore..  :-)

paights 0 solutions 1 answers

Helpful Reply

I think I found out the "loophole".

I also had the same problem as you guys. Was not amused at all with VUZE. But really wanted to use the tool.

- Uninstall VUZE

- Reinstall VUZE

 - select   customize   
 - Click = I Agree
 - Click  = Next
 - Then = Decline

Problem solved.

Cheers

MattF 1 solutions 4 answers

I've now had this happen to me (at least) twice. It won't be happening again.

- Uninstall VUZE

- Uninstall any VUZE related item

- Do NOT Reinstall any of it.

It used to be a good program. No longer.