X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox deleted all my passwords and usernames

Posted

Firefox 17.0.1 for Mac deleted all my logins (no warning) and does not save any password ; it used to do that but now this does not work

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Glims Plug-in for Safari
  • Version 3.10.2.10212
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Net iD Plugin
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Nexus Plugin, providing authentication and signing features

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

Try to restore the key3.db and signons.sqlite files via the Time Machine in case the current files are corrupted.
If this isn't possible then remove the current key3.db and signons.sqlite files to make Firefox create new files.

See Troubleshooting:

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Question owner

Without doing anything, all passwords reappeared one day ! So now I wonder what bevaviour is this ? can I recover passwords stored in FireFox from Time Machine ?

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

The only way to merge passwords is to export existing passwords via this extension and swap the two files key3.db and signons.sqlite to get the other set and then re-import the saved passwords.

Question owner

FF does not automatically fill in my logins WHy not ?

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

You can also check the value of the signon.autofillForms pref on the about:config page.

Question owner

Remember I am a Mac user. The Use Custom Settings for History is under Preferences (not Tools) This setting is not saved. It always is Remember History

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96842 answers

Sorry about the menu path for Windows.

Seeing "Remember History" means that all history and cookie settings are set to the defaults.
The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.

If the settings are correct then you may have an extension that is preventing filling passwords.

Do all the names and passwords show in the password manager?

Do you get a drop down list when you type the first letters of a stored name in a website form?

Question owner

It seems to work now, but who knows for how long ? there are always surprizes...