X
Tap here to go to the mobile version of the site.

Support Forum

can not remove yahoo search engine from search bar

Posted

I have tried to use the suggestions listed but I am very dense and need a walk through. How do I permenently remove yahoo search from my list of search engines? I can remove it by manage search engines... but it comes back.

I have tried to use the suggestions listed but I am very dense and need a walk through. How do I permenently remove yahoo search from my list of search engines? I can remove it by manage search engines... but it comes back.

Chosen solution

The easiest way to get Google as your search engine. is on the top right corner as in my photo, click on what ever your search engine is and be sure to choose Google as your search bar. after this click on the magnify glass in the same search bar. it takes you to Google home. just copy the URL when you get there and then go to 'tools' choose 'options' in the 'general tab. you can either paste the URL or choose 'use current page. when that's complete, your problems are fixed.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Picasa plugin
  • 4.1.10329.0
  • WordCaptureX component for single click dictionary
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

iamjayakumars 475 solutions 5852 answers

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  1. Enter about:config in the Firefox location bar and press Enter.
  2. You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  3. In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  4. Right-click on the keyword.URL setting and select Reset from the dropdown menu.

Now you're done. Please report back if this fixes your problem. Thanks in advance!

You can find more information about the Location bar search feature in the Search the web from the address bar article.

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps: #Enter about:config in the Firefox location bar and press Enter. #You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the ''I'll be careful, I promise'' button to continue. #In the Search box at the top, enter ''keyword'' as the search term. You should see a few remaining items, one of these is ''keyword.URL''. It should be bold. #Right-click on the keyword.URL setting and select ''Reset'' from the dropdown menu. Now you're done. Please report back if this fixes your problem. Thanks in advance! You can find more information about the Location bar search feature in the [[Location bar search]] article.

Question owner

thank you for your suggestion. however it did not work. I had removed yahoo search before I selected reset. upon reseting yahoo poped right back in. any other suggestions?

thank you for your suggestion. however it did not work. I had removed yahoo search before I selected reset. upon reseting yahoo poped right back in. any other suggestions?
cor-el
  • Top 10 Contributor
  • Moderator
12765 solutions 117276 answers

If you can't make permanent changes to the search engines then it is possible that an extension in interfering.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

If you can't make permanent changes to the search engines then it is possible that an extension in interfering. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- *http://kb.mozillazine.org/Unable_to_search_or_add_new_engines *http://kb.mozillazine.org/Search_Bar

Question owner

I thought that this problem was fixed, but somehow it there again. any other suggestions?

I thought that this problem was fixed, but somehow it there again. any other suggestions?
cor-el
  • Top 10 Contributor
  • Moderator
12765 solutions 117276 answers

You did check for extensions, because there are extensions that silently install other components to set a specific search engine?

You can try to delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

You did check for extensions, because there are extensions that silently install other components to set a specific search engine? You can try to delete the search.json file and a possible search.sqlite file in the Firefox Profile Folder. *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Unable_to_search_or_add_new_engines ---- Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
ronh47 0 solutions 2 answers

I had the same problem...I searched many forums for answers...Finally this one works. Click Start....Click Run...enter this: c:\program files\mozilla firefox\searchplugins A page opens showing all the search engines in firefox. Simply right click the ones you do not want and delete. It has been a week now and Google is still my only Search engine

I had the same problem...I searched many forums for answers...Finally this one works. Click Start....Click Run...enter this: c:\program files\mozilla firefox\searchplugins A page opens showing all the search engines in firefox. Simply right click the ones you do not want and delete. It has been a week now and Google is still my only Search engine
FrustratedMe 0 solutions 1 answers

Helpful Reply

I must warn you that I have no expertise, but this worked: Type "about:config" in the address bar. Search for "yahoo". Reset them all to "default". It worked. Yahoo is gone. I tried every answer given to this problem except the one where you reset Firefox and started over. I hate bleeping Yahoo. They've done this to me so many times I can't count. Mozilla should make an anti-yahoo app.

I must warn you that I have no expertise, but this worked: Type "about:config" in the address bar. Search for "yahoo". Reset them all to "default". It worked. Yahoo is gone. I tried every answer given to this problem except the one where you reset Firefox and started over. I hate bleeping Yahoo. They've done this to me so many times I can't count. Mozilla should make an anti-yahoo app.
YAZOOMILLER 0 solutions 3 answers

Helpful Reply

To get rid of Yahoo from locking itself in the search space, I found two ways to unlock Yahoo (get rid of Yahoo)

 #1. same as above;  a.) type in the address bar "about:config",  b.)search for "yazoo",  c.)sort the 'preference name' column,  d.)find "browser.search.defaultenginename",  e.) change the value to "default".    This way is a cleaner way to get to the same result as above - I am only cleaning the steps up.
  #2.The other way to get Yahoo (or any other site name) from locking your search to one entity (Yahoo) is get to your to..  C:Documents and Settings/ Owner/ Application Data/ Mozilla/ Firefox/ Profiles/ Z1RF8c0j.default (this string may be different - I don't know if is created when this action is processed to make Yahoo the 'locked in' default - you may have to open and look in each file in the Profiles folder for "ABE" item to continue)/ ABE/ Searchplugins/ yahoo.xml [infact - any Yahoo's in this list] DELETE them all.... Then look at your 'Search' in the upper right hand corner of Firefox = Yahoo will be gone and you can select one of any search entity you choose from your list.
To get rid of Yahoo from locking itself in the search space, I found two ways to unlock Yahoo (get rid of Yahoo) #1. same as above; a.) type in the address bar "about:config", b.)search for "yazoo", c.)sort the 'preference name' column, d.)find "browser.search.defaultenginename", e.) change the value to "default". This way is a cleaner way to get to the same result as above - I am only cleaning the steps up. #2.The other way to get Yahoo (or any other site name) from locking your search to one entity (Yahoo) is get to your to.. C:Documents and Settings/ Owner/ Application Data/ Mozilla/ Firefox/ Profiles/ Z1RF8c0j.default (this string may be different - I don't know if is created when this action is processed to make Yahoo the 'locked in' default - you may have to open and look in each file in the Profiles folder for "ABE" item to continue)/ ABE/ Searchplugins/ yahoo.xml [infact - any Yahoo's in this list] DELETE them all.... Then look at your 'Search' in the upper right hand corner of Firefox = Yahoo will be gone and you can select one of any search entity you choose from your list.
Wolfeyez 0 solutions 4 answers

Yes, "Yahoo" default search can be difficult to remove as most people report back that no matter what they do, "Yahoo" returns as a default search tool. Frustrating, we what our "Google" back!

Try this...Upper left, click the orange "Firefox" tab or "help" from the menu bar, from there click on "Troubleshooting Information", then click on the button "Reset Firefox to its default state" (don't worry, bookmarks, etc, will not be affected).

Ahhh, "Google" is back as the default search engine.

Yes, "Yahoo" default search can be difficult to remove as most people report back that no matter what they do, "Yahoo" returns as a default search tool. Frustrating, we what our "Google" back! Try this...Upper left, click the orange "Firefox" tab or "help" from the menu bar, from there click on "Troubleshooting Information", then click on the button "Reset Firefox to its default state" (don't worry, bookmarks, etc, will not be affected). Ahhh, "Google" is back as the default search engine.

Modified by Wolfeyez

Wolfeyez 0 solutions 4 answers

Yes, "Yahoo" default search can be difficult to remove as most people report back that no matter what they do, "Yahoo" returns as a default search tool. Frustrating, we want our "Google" back!

Try this...Upper left, click the orange "Firefox" tab or "help" from the menu bar, from there click on "Troubleshooting Information", then click on the button "Reset Firefox to its default state" (don't worry, bookmarks, etc, will not be affected).

Ahhh, "Google" is back as the default search engine.

Yes, "Yahoo" default search can be difficult to remove as most people report back that no matter what they do, "Yahoo" returns as a default search tool. Frustrating, we want our "Google" back! Try this...Upper left, click the orange "Firefox" tab or "help" from the menu bar, from there click on "Troubleshooting Information", then click on the button "Reset Firefox to its default state" (don't worry, bookmarks, etc, will not be affected). Ahhh, "Google" is back as the default search engine.

Modified by Wolfeyez

Olga Kovshanova, MBA, MA 0 solutions 1 answers

FrustratedMe: Thanks--your solution seems to have ridded my FireFox of Yahoo in the search bar! Hoping Yahoo search will not re-inset itself!!

Spam removed. See Forum rules and guidelines. aw

FrustratedMe: Thanks--your solution seems to have ridded my FireFox of Yahoo in the search bar! Hoping Yahoo search will not re-inset itself!! <!--Olga Kovshanova, MBA, MA Hotel Professional Extraordinaire General Manager Bangkok, “The Best City in the World”, Travel and Leisure! The Best Luxury Classic Diamond Boutique Hotel in Bangkok: The Eugenia!! A Compass Hospitality managed Gem Email: olinka@olinka.info Professional Website: http://www.olinka.info/ Skype name: olinkaru M: +66-88-499-7785 LinkedIn Profile: http://www.linkedin.com/in/kovshanovaolga Leader LinkedIn Group: Hotel Professionals Worldwide http://www.linkedin.com/groups/Hotel-Professionals-Worldwide-4333308 --> <sub>Spam removed. See [[Forum rules and guidelines]]. aw</sub>

Modified by AliceWyman

smokiejoes 1 solutions 1 answers

Chosen Solution

The easiest way to get Google as your search engine. is on the top right corner as in my photo, click on what ever your search engine is and be sure to choose Google as your search bar. after this click on the magnify glass in the same search bar. it takes you to Google home. just copy the URL when you get there and then go to 'tools' choose 'options' in the 'general tab. you can either paste the URL or choose 'use current page. when that's complete, your problems are fixed.

The easiest way to get Google as your search engine. is on the top right corner as in my photo, click on what ever your search engine is and be sure to choose Google as your search bar. after this click on the magnify glass in the same search bar. it takes you to Google home. just copy the URL when you get there and then go to 'tools' choose 'options' in the 'general tab. you can either paste the URL or choose 'use current page. when that's complete, your problems are fixed.

Question owner

thank you all for the suggestions. I have figured out a way around the problem. problem is solved, for now.

thank you all for the suggestions. I have figured out a way around the problem. problem is solved, for now.