X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Secure startup home web page not loading in FF 17.0.1

Posted

Have https://www.google.com/ set as home page.

What I get: Go to a website

What I do: click Bookmarks>Google url link

Result: https://www.google.com

Go to a website does result in Google home page loading, but it appears to be loaded locally, not via an internet connection. Have Flagfox installed as an add-on, but this does not load until I do step 2, and only then is any activity seen in the lower left hand corner of the browser as the Google page loads.

Odd thing is, without an active internet connection, FF reports page not found error and Google is not displayed.

Note that step 3 is missing a backslash at the end of the url, even tho it is set and entered properly in Options for General>Startup.  ???

A https connection should also be green if valid, and I am not seeing that on most https sites. GRC.com does show this green color, but that is the only one that seems to work for me. Clicking the lock icon does give me vendor ownership information; the others state 'unknown'. Example: "You are connected to mozilla.org which is run by (unknown) Verified by GeoTrust, Inc. Your connection to this website is encrypted to prevent eavesdropping.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Foxit Reader Plug-In For Firefox and Netscape
  • 5.1.10411.0
  • DivX Plus Web Player version 2.2.0.52
  • DivX VOD Helper Plug-in
  • Office Live Update v1.5
  • 1.9.0042.0
  • npdivxplayerplugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Have disabled FlagFox extension to see if that would change secure page loading in Google since it is not loading at all on startup. No change.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

You only see a green color in the Site Identity Button if websites use an Extended Validation (EV) SSL Certificate and not if a Domain Validation (DV) SSL Certificate is used like this SUMO forum site is using.


Firefox may be loading pages from the Firefox browsing cache if they aren't loaded from the internet.
You may also have other software or a router that caches some pages.

Which security software (firewall, anti-virus) do you have?

Did you check that your security software isn't blocking the connection?

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

hi cor-el,

Using OpenDNS free if that makes any difference. Have a registered user account there.

Avast! free 7.0.1747, Online Armor free 6.0.0.1736.

What setting in OA would partially block https connections? Where to look?

Will test in SM/network enabled to see if any difference and report back. Note that OpenDNS will not be enabled either here as well.