X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I disable the drop-down list of suggested sites shown on my address bar?

Posted

As you type into the address bar, Firefox displays a drop-down list of suggested sites and actually the pages I have visited.I want to know how can I disable that ? Is that possible? I don’t like it it’s not useful and it’s so unsecure now every body that doesn’t know anything about computer is able to know what pages I visited before if he can be behind my desk.

Chosen solution

You can disable the suggestion via:

  • Firefox/Tools > Options > Privacy > Location Bar: When using the location bar, suggest: Nothing
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.69
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Chosen Solution

You can disable the suggestion via:

  • Firefox/Tools > Options > Privacy > Location Bar: When using the location bar, suggest: Nothing

Modified by cor-el

Question owner

I should have known my savior Cor-el again. just the answer. thanks man thanks a lot.

Roger1712 0 solutions 4 answers

My settings are right but I still get suggestions when I type in the url bar.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

You can check on the about:config page if the browser.urlbar.autocomplete.enabled pref is set to false if you want to disable the location bar drop down list.