X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Java and mozilla plugin check problem.

Posted

Hello, I've encountered some problems with java plugin( SE 7.0.90.5 10.9.2.5) and mozilla plugin check site. I'm always checking whether my plugins are up to date, so today I did this check and plugin check told me, that java plugin was "outdated". But, it turns out, there is no new version of java plugin. Ok, maybe glitch or something like that, so I reintall plugin- plugin check still shows the same message - "outdated". I swtiched to safe mode in Firefox, tried to delete pluginreg.dat file from profile directory, even reinstalled Firefox itself. Nothing helped. Maybe someone could help me out with this one. Would be great to know what caused this error.

P.S. I'm using Firefox 17.0.1 on Windows 7 64bit. Plugins I'm currently using:

  • Java Platform SE 7.0.90.5 10.9.2.5
  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Silverlight 5.1.10411.0

Modified by Sutemos

Chosen solution

See my earlier answer to another user at https://support.mozilla.org/en-US/questions/944169#answer-388396

  • Note the part about needing to exit/close your browser after installing for the Plugin Check page to detect the new version of Java.

You can also download the JRE at (download, save, exit close browsers, run the file that you downloaded)- http://www.oracle.com/technetwork/java/javase/downloads/index.html

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • VLC media player Web Plugin 2.0.2
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

TheOldFox 110 solutions 619 answers

Chosen Solution

See my earlier answer to another user at https://support.mozilla.org/en-US/questions/944169#answer-388396

  • Note the part about needing to exit/close your browser after installing for the Plugin Check page to detect the new version of Java.

You can also download the JRE at (download, save, exit close browsers, run the file that you downloaded)- http://www.oracle.com/technetwork/java/javase/downloads/index.html

Modified by TheOldFox

Question owner

Ha, it seems I was using wrong site for downloading java plugin. Anyway, my problem is solved. Thank you very much for your fast response, TheOldFox.

SunnyValencia 0 solutions 10 answers

OK... so... I used the Java applet to install 10 and FF said it's disabled java as an 'outdated' version.....would I like to install it. So... I do and now have both 9 and 10 installed..... but FF is happy again.

Usurp 0 solutions 1 answers

Helpful Reply

I have this problem too. These are the plugins shown into the Firefox plugin manager :

Java deployment Toolkit 7.0.90.5 10.9.2.5

Java(TM) Platform SE 7 U9 10.9.2.5

I closed Firefox, uninstalled Java entierely, rebooted, and installed it again. The plugins check page still shows an obsolete version for the 2 plugins.

Modified by Usurp