X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox hangs/crashes wont' load; i've uninstalled/reinstalled; safe mode also; older version also; it used to work

Posted

Firefox was working prior to updating to version 17. Then when I click it, it won't start. I tried to start in Safe Mode, also Reset Mode. I tried to uninstall version 17, and do a clean install. Also, I cannot run an older version of Firefox since there is something wrong with my System Restore which isn't keeping a copy. I have been doing things for sometime now. The addons don't seem to be the problem meaning it will start briefly once or twice, but it won't keep working. It just says to start in Safe Mode or Reset, it works once, then same problem reappears. Thanks. also, i've looked at the Profiles, but when I do, it also has a problem starting so I can't create a new profile. I've also tried running Firefox 14. Same thing. Everything is working same way. Any help is badly needed? I have also tried to run malware software. I can't do the memtest. Its too hard for me to try, but I don't think it's my memory. I stopped using FF since it's taken so long to try to fix. I don't won't to do a complete restore of my computer, but it sounds like my only option. What could possibly be wrong? Do I need to show you a HIjack this file. Thanks.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.91 Safari/537.11

More Information

Question owner

Thank you very much for your reply. Sorry It took so long to reply. I really appreciate the link. The other general posts in this forum didn't work, but going through your link it was solved. The problem may have somehow been caused by my network cache. I also haven't been using Firefox for awhile. I hope it stays fixed. Thanks a lot!

Question owner

Unfortunately, the problem has reoccurred. The solution which worked is no longer working. I am working on these steps. I had seen this before it was posted here as a reply. I had missed one of the early steps. I have done a lot of the steps before and need to try them again. Thanks for the effort. I'll let you know how it goes.