X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Upgrading to the latest version of Firefox would cost me about $2,500 so why am I mad?

Posted

I have a Mac G5 with OS 11.4.11. In order for me to upgrade to the latest version of Firefox I would have to install a new system. If I install a new system I have to install all new programs. Adobe Photoshop, Illustrator, InDesign, GoLive and other CS programs, plus PowerPoint, QuarkXpress , and many others. I can't afford to upgrade. I really like Firefox but what am I suppose to do?

Chosen solution

Additional System Details

Installed Plug-ins

  • Gecko default plugin
  • Shockwave Flash 10.1 r53
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.22) Gecko/20110902 Firefox/3.6.22

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10743 solutions 96657 answers

Chosen Solution

Firefox 4 and later require a Mac with an Intel processor and OS X 10.6 (Firefox 16 runs on OS X 10.5).

For an unofficial Firefox 17.0 ESR compatible version (TenFourFox) that runs on PowerPC Macs with OS X 10.4.11 or OS X 10.5.8 you can look at:

klneill 0 solutions 1 answers

I have used TenFourFox for a little while now on my G5 Tower. It works alright - better than Firefox has in recent weeks, anyway. And there's always IE on my PC laptop, push comes to shove.

As for Firefox: they've lost me with this move. There is no way I am replacing a perfectly wonderful Mac and thousands of dollars worth of software to play upgrade games with a browser. I used to recommend Firefox to friends. Never again.

Modified by klneill