X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

ReCAPTCHA does not appear

Posted

Brand new FF 17.0.1 install. Apparently over the best FF: 3.5.

Steps to reproduce:

1. going to web page with recaptcha on it. 2. Does not appear. 3. Inspect it with "firebug" and between the script tags it says "Reload the page to see the source of https://www.google.com/....." 4. Refreshing the page does nothing. 5. Take the google URL and put it into new tab 6. the new tab says the (domain/cert?) isn't allowed, but allows me to add an exception for it. 7. I click "Add Exception" and it spits back the Javascript. 8. Go back to the original tab 9. F5 10. recaptcha now works.

This page works in FF3.5, and all versions of IE and Chrome attempted. Has the same non-working behaviour in FF14. Both FF's are on Win7.

[Profanity removed by moderator. Please read Forum rules and guidelines, thanks.]

Modified by Chris Ilias

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 11.0 r1
  • Unity Player 3.4.1f5
  • BlackBerry WebSL Browser Plug-In
  • SOE Web Installer
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • Yahoo Application State Plugin version 1.0.0.7
  • Comrade Plugin
  • Zylom Plugin
  • 3.0.40624.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

No longer meaningful because I made it work using the above directions.

jscher2000
  • Top 10 Contributor
2364 solutions 20919 answers

Can you link to an example page using Recaptcha? It's not so easy to search for one...

When I visit https://www.google.com/recaptcha I do not see any problem with the certificate. If you switched from 3.5 directly to 17, I wonder whether the root certificate file was behind on updates? Might not be possible to re-create the problem at this point.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96748 answers

Helpful Reply

Try to rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file.
Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates.
Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

See also:

Question owner

> jscher2000

For privacy's sake I'm not going to post a https Google Recaptcha link - I just don't know of independent ones - or haven't run across them since switching FF in the last day.

This problem appears for me for (all?) https after changing to FF17 - including this support page: the favicon.ico doesn't load because I haven't forcibly loaded that file into a separate tab and given it permission. Pages and websites I've used for a DECADE I've had to find their CSS/CDN server and give that permission so I see the CSS, images and get the JS files downloaded.

I don't know the history of FF by the person using FF14/Win7 who originally reported the problem. Completely separate user, same problem.

I suppose this is the place to say: in FF3.5 one reason I kept that version was because any FF upgrades I tried kept reinstating all the CAs and made it stupid-hard to remove them - and I trust no one, especially trackers, google, etc. And since FF doesn't have a setting to ask me if I want to make connections to every server a web page uses (and keeping a block list for me)...Ugh. After installing FF17 I went in and deleted every CA. Of course the next time I opened the exact same Options tab every CA was listed once again, so I really can't trust FF as far as I can throw it on a jumpdrive.


> cor-el

Off to try your suggestion. BTW It looks like my cert_override.txt file is pretty tiny, and the file you mentioned only appears in the Roaming profile (I've never made a new profile).

Modified by whocares

Question owner

> cor-el

Renaming cert8.db now allows this website's favicon to appear. The newly generated cert8.db is less than 1/10th the size of the original.

While this is a local possible solution (helpful: yes, solution: not yet), there are many questions which need answering:

1. what does this do to my FF? What is being let in now that wasn't before? What security holes have I just opened?

2. why was/is this a problem in newFFs but not back in FF3.5?

3. what could have affected cert8.db in this way? Primarily I need to know who is going to have this same problem for the same - and different - reasons than I did.

Basically, why did this help with embedded https and what do I lose by going with this solution?

Thanks! There *is* hope!

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96748 answers

It is possible that you had outdated or otherwise corrupted intermediate certificates stored in the cert8.db file and that this prevented Firefox from establishing a secure connection.
Such problems can also be caused by saving a permanent exception when you had a problem in the past and forgot about those.
It is usually better not to save a permanent exception, but try to find the cause and either see if you can install a missing intermediate certificate or ask for help on a forum or contact the website.

jscher2000
  • Top 10 Contributor
2364 solutions 20919 answers

And since FF doesn't have a setting to ask me if I want to make connections to every server a web page uses (and keeping a block list for me)...

A future version of Firefox will at least not load http content on an https page. With respect to individual site loading/non-loading, the NoScript extension is useful for managing scripts. I think there are Flash blockers that also let you approve sites. No idea whether a similar tool exists for other kinds of content.