X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

MacBook Pro can't open in Firefox, always goes to Safari

Posted

I have a MacBook Pro - OS X, 10.8.2, and want the default browser to be Firefox, not Safari.

The consistent advice is: Safari/Preferences/General and showing Firefox as the default browser. I have done this, and when I start up I keep getting Safari, not Firefox. I can then click on Firefox from the Launchpad and it comes up and works fine; I would just like to avoid the extra steps I take to quit Safari and start Firefox. The Apple representative with whom I spoke took me through the above steps and was baffled that it didn't work. She suggested that I contact Firefox, so that's what I am doing. Please help. There must be some setting I have inadvertently done to myself.

Thanks. Rob Jones

Chosen solution

Hello robertsonjones, quit Safari and then go to Hard drive > Users > Your Username > Library > Preferences > Trash the com.apple.Safari.plist

or go from : Finder > Go menu > Go To Folder type ~/Library/Preferences click Go scroll find com.apple.Safari.plist , and Trash the folder.

this is in case that safari preferences are not saved


thank you

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

ideato
  • Top 25 Contributor
616 solutions 4260 answers

Chosen Solution

Hello robertsonjones, quit Safari and then go to Hard drive > Users > Your Username > Library > Preferences > Trash the com.apple.Safari.plist

or go from : Finder > Go menu > Go To Folder type ~/Library/Preferences click Go scroll find com.apple.Safari.plist , and Trash the folder.

this is in case that safari preferences are not saved


thank you

Helpful Reply

Solved my problem!! Thanks!!