Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

google search does not show results must press RELOAD button for it to work

  • 26 replies
  • 37 have this problem
  • 3841 views
  • Last reply by cor-el

more options

Hello, I am using FF 17.0. This just started recently. When I go to Google and enter a search word and hit "enter" the results page loads with just the top header and a blank screen otherwise. I need to hit the RELOAD button in the address bar for everything to complete with results..

Then, after scrolling thru the results to the bottom of the page and hitting ENTER to go to the next page, again the same thing happens. I need to hit the RELOAD button again for more results.

This happens for every search I do when using FireFox. It works perfectly fine in IE. I hate IE.

Any help would be greatly appreciated.

All Replies (6)

more options

You're welcome.
Thanks and best wishes to you and your family too.

HTTP pipelining is one of the things that can have adverse effects if a server doesn't support this feature properly.
If it does support it then it may work.
Those tweaks aren't really needed and what you gain may slow down access for others (a server can only handle a maximum amount of traffic).

more options

this seems to have been fixed now, by google...

more options

Yes, see:

Google has pushed a fix for this issue. Please test and let us know if there are any more problems.

Modified by cor-el

more options

No, as I wrote, it's not related to Google, but to other sites as well. However I have done some cleaning from some recommendations mentioned by cor-el and that actually seemed to help! It could also have been SunnyValencias tip on DOM.STORAGE.

So thanks again cor-el and Sunny!

Modified by johanfromsweden

more options

HEY I just wanted you guys to know this is not unique to Mozilla, I use the CHROME browser, and I have been having the SAME exact problem and since about this same time period.

I can't find any information online about CHROME having the problem, so I finally broke down and am looking in the Mozilla support. Let's face it man, you guys have excellent support anyway. Google support is a joke.

My javascript is DISABLED and has been pretty much for months, so I don't think that's it.

I also checked that link from cor-el, and some examples of having to hit send again before the results will show are the same and similar, but in my case usually hitting send results in NOTHING. No reload at all. It doesn't matter how many times I hit it, I can hit the reload button and nothing happens. It just dies.

IF I enter a new search IF it does anything at all, it will simply show the results from the old search a second time, the new search parameters won't show up in the URL line.

Unfortunately there is no about:config on CHROME so I can't find that DOM.STORAGE.

I just wanted you all to know how much I appreciate the fact that you are at least talking about it. CHROME doesn't seem to want to admit there is a problem.

ALSO it all started right about the time they rolled out the 'similar results' function, a completely worthless addition and time wasting function that nobody likes or wants. I guess they wouldn't dare admit it might be causing problems with the searches in their own browser!!

THANKS !

more options

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

  1. 1
  2. 2