X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I make Google my default search engine when I switch tabs?

Posted

I want it so that when I go to a new tab, Google.ca is the search engine, not Ask.com.

Additional System Details

Installed Plug-ins

  • Facebook Video Calling Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • SiteAdvisor
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
2363 solutions 20914 answers

Helpful Reply

You probably need to disable or remove an add-on that introduced Ask to Firefox. The add-on might not have an obvious name, so try disabling ALL nonessential extensions here:

orange Firefox button or classic Tools menu > Add-ons > Extensions category

Then restart Firefox. You also might need to reset your default search provider. You can do that in several manual steps, or you could try this add-on: https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Does that help?

jscher2000
  • Top 10 Contributor
2363 solutions 20914 answers

Helpful Reply

I realized I didn't ask you something: did you want to change what an address bar search does, or do you want Google to appear in the new tab in place of the thumbnails / blank page / Ask page?

To change what appears in the tab (after removing any problem extensions), you can use Firefox's about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value:

(i) Page thumbnails (default)

browser.newtab.url = about:newtab

(ii) Blank tab

browser.newtab.url = about:blank

(iii) Built-in Firefox home page

browser.newtab.url = about:home

(iv) Any other page

browser.newtab.url = full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Question owner

I tried this but it didn't work. Hmmm....

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96745 answers

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.