X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Background printing does not work

Posted

Background images does not print from today from about 12.30pm

Changed nothing. Not sure if FF updated during the period or not. Did restore to 6am to make sure. Reset Firefox. Restarted computer. Checked printer drivers - ok.

Shows up without background images in "print preview". But no difference when pressing print background images/not.

Worked fine prior to 12.30pm today.

Any ideas?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.0"
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Firefox 17.0.1
XP
Oki printer

Gryllida 76 solutions 892 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.


Please let us know whether the issue persists in the Firefox's safe mode. Thanks!

Question owner

Thanks.

Tried. Did not solve issue.

Have also tried about:config: printer_OKI_MB480.print_bgcolor;true printer_OKI_MB480.print_bgimages;true

no difference.

dedicatedmanager 0 solutions 3 answers

Same problem here. It quit working a few days ago, probably about Dec 5th for me as well. I hadn't touched any configuration settings.

Question owner

Hi

Answer did not help. I thought it might have to do with antivirus, but have changed this (as it was overdue anyway). Now think may be an issue with XP as I am printing ok from the same website on a Vista computer on the same network.

dedicatedmanager 0 solutions 3 answers

I don't think its operating system (version) specific, I'm on Windows 7.

dedicatedmanager 0 solutions 3 answers

I don't think its operating system (version) specific, I'm on Windows 7.

luckyluke 0 solutions 1 answers

Same problem here. Started after Firefox updated. Tried safe mode still same problem. This sucks big time, since I have to print my invoices (osc) with backgrounds or else it looks like crap. Back to IE for now, sigh...

Question owner

Yup, same here. OsC packing lists in my case. I have a computer with Vista I am using to print these and for some reason this works fine. Dont ask me why.

I chased my IT guy but found that its a local issue with my computer, but have tried everything, even the disabling and stuff. it doesnt look nice as you mention and we even discussed to create table boxes instead of using rounded corners as a way forward.

Question: Can I ask who you use for your OsC work? External or yourself?

316firefox 0 solutions 1 answers

any update on this?

Gryllida 76 solutions 892 answers

No update that I am aware of, please, file a bug. It's easy; here's how: https://developer.mozilla.org/en/docs/Bug_writing_guidelines

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96777 answers

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

See also:

Modified by cor-el

Gryllida 76 solutions 892 answers

cor-el, thanks, please try it for yourself and check it out

1) go to http://www.w3schools.com/css/tryit.asp?filename=trycss_background-image

2) file -> page preview contains no background in the right pane

this also happens in safe mode ...

Modified by Gryllida

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96777 answers

I don't have a printer, but a preview doesn't show the background, but printing to PDF does give the page with a background in the resulting document.

Gryllida 76 solutions 892 answers

neither print preview nor the resulting PDF file have the background for me "Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0" here ... same in safe mode ...

What OS are you using?

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96777 answers

OpenSUSE Linux with the system print to PDF printer and printing background colors and background images enabled for this test.

This is a screenshot with the Adobe Reader and pdfjs.

Gryllida 76 solutions 892 answers

...

I have no idea what is happening, my distro does not have the image in the PDF unlike you described. I don't know how to troubleshoot the issue (could you try with a fresh VM with Ubuntu in it maybe?).

nightsmusic 0 solutions 12 answers

I'm having the same problem and have been since mid December when Firefox updated. It's terrible because I print a lot of Google maps and only the words and the very dark streets show up. None of the streets which look like pencil lines, nor the house plots or other things show up though they all do in Print Preview. I'm on Firefox 18.0 now and it's not getting any better! And Windows 7 OS.

fixxer 0 solutions 1 answers

Same problem on all computers in the company that I work in since the mid December. Background images are not printed. Also not showing them in the print preview.

Question owner

been reported already:

https://bugzilla.mozilla.org/show_bug.cgi?id=819922

If you added this, can you please refer to this thread in the bug report?