X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Disable 'plugin-container' in FF 17?

Posted

I've done it before with previous versions of FF but I forgot how. It's very simple, I want to disable this 'plugin-container.exe' and let the plugins run within the FF.exe thing.

The previous version I WAS (no italics) using I had it disabled. I clicked 'About FF' to figure out what version I was using and this farging thing just automatically updated and now I have to deal with this greedy plugin container.

So, I do this?

1: type in about:config 2: look for (need file/field names) 3: change certain fields to 'false'

Again, I just need the field names for 2 and 3. Please don't refer me to some useless link.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Yahoo Application State Plugin version 1.0.0.7
  • Version 0.9.19, Copyright 2006-2012 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10757 solutions 96832 answers

See:

Question owner

What a headache. Thanks for the useless link.

cor-el
  • Top 10 Contributor
  • Moderator
10757 solutions 96832 answers

Which prefs do you currently have if you search for dom.ipc.plugins.enabled on the about:config page?

gonehazel 0 solutions 13 answers

Helpful Reply

One more time...setting dom.ipc.plugins.enabled to false DOES NOT STOP PLUGIN CONTAINER!!!! Please stop giving this answer as a solution, Cor-el. It is simply wrong.

cor-el
  • Top 10 Contributor
  • Moderator
10757 solutions 96832 answers
278   // On Windows Vista+, we force Flash to run in OOPP mode because Adobe
279   // doesn't test Flash in-process and there are known stability bugs.