X
Tap here to go to the mobile version of the site.

Support Forum

When I try to upgrade I get a screen that says I don't have the right requirements,so what is required to automatically upgrade?

Posted

I've tried repeatedly. The requirements hyperlink doesn't work. Should I uninstall then reinstall?

I've tried repeatedly. The requirements hyperlink doesn't work. Should I uninstall then reinstall?

Additional System Details

Installed Plug-ins

  • Version 3.10.2.10212
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

More Information

cor-el
  • Top 10 Contributor
  • Moderator
12487 solutions 115209 answers

Firefox 17 will require OS X 10.6 and later, so you need to update your Mac if you want to continue using Firefox beyond Firefox 16.

You can see the Firefox 17 system requirements here:

Firefox 17 will require OS X 10.6 and later, so you need to update your Mac if you want to continue using Firefox beyond Firefox 16. You can see the Firefox 17 system requirements here: *http://www.mozilla.org/en-US/firefox/17.0/system-requirements/ *http://blog.mozilla.org/futurereleases/2012/10/04/we-bid-you-adieu-spotted-cat/

Modified by cor-el