X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can only open one link at a time; any page in new tab will seem to load but appears blank. I have to open a new browser to go to a new page. Why?

Posted

This just began to happen yesterday. I have a MacBook Pro 10.7.5. I can always get to the first page that I open in a new browser, but any page after that that I try to open in a new tab will seem to load but the page is blank. This does not just happen with one website I have tried myriad of different sites.. only the first tab loads in a new browser. I am having to open a new browser if i want to go to another link - very frustrating..

Chosen solution

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Shockwave Flash 11.4 r402
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Picasa plugin.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • 5.1.10411.0
  • Facebook Video Calling by Skype
  • Plugin for Wacom tablets.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/18.0 Firefox/18.0

More Information

I have tried to clear all my history including cache and cookies and then restart FF - problem continued to happen.
I am not sure what else to do.. this is weird.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Chosen Solution

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Thank you so much. I had tried this before and it fixed the problem, and then I re-installed all my add ons that I had before. When I did this the same problem began to happen! So it was obviously one of the add-ons. I went through the restart FF process again and installed my add-ons one by one to see which one was causing the problem. I found that it was New Tab King causing this problem! I have had New Tab King for at least a month now and this never started happening until today... weird... but great to have it figured out! Thank you so much! Beware of New Tab King!

newtabking 0 solutions 2 answers

Helpful Reply

Hi - This is Eddie from NTK. We just released an updated version handling the new Firefox Beta - please grab it from https://addons.mozilla.org/en-us/firefox/addon/new-tab-king/versions/

Apologies for the bad experience. We're working hard to chase the never-ending Mozilla release train... --eddie

Question owner

Eddie/NTK people - Thank you so much. I've had nothing but good experiences with New Tab King prior to this and I figured it was an issue with updates etc...

Thanks a bunch for the speedy reply and fix! I am back to using the new NTK :)

newtabking 0 solutions 2 answers

Glad this worked out. Feel free to contact us at support@newtabking.com if you need anything. --eddie