X
Tap here to go to the mobile version of the site.

Support Forum

I teach online and firefox is recommended, Recently, the email functions quit working. They work with Explorer but not firefox. I want to use firefox.

Posted

When using Firefox, I can work in LoudCloud, which is Grand Canyon University's program; however, any locations from which I send students emails, comments, answers to questions, etc., is no longer working. It works when I switch to Internet Explorer, but I want to use Firefox. It is more user-friendly. Should I re-download Firefox?

When using Firefox, I can work in LoudCloud, which is Grand Canyon University's program; however, any locations from which I send students emails, comments, answers to questions, etc., is no longer working. It works when I switch to Internet Explorer, but I want to use Firefox. It is more user-friendly. Should I re-download Firefox?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • McAfee MSC FF plugin DLL
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.2"
  • Dragon NaturallySpeaking Rich Internet Application Support - Plugin
  • 4.1.10329.0
  • SiteAdvisor
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Logitech Harmony Remote Plugin
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

jscher2000
  • Top 10 Contributor
8785 solutions 71850 answers

Could you check which mail program or site is set to handle "mailto" links and try resetting it:

orange Firefox button or classic Tools menu > Options > Applications

In the search box, type or paste mailto and pause while Firefox filters the list. You should get one row with a drop-down on the right that lets you choose your mail program or site. If your program is not selected, go ahead and change it now. If it is already selected, try refreshing the setting by changing to another program or site and OK out of the dialog. Then go back and change it back.

Does that make any difference? If I have misunderstood the email feature you're trying to use, could you describe it in more detail?

Could you check which mail program or site is set to handle "mailto" links and try resetting it: orange Firefox button ''or'' classic Tools menu > Options > Applications In the search box, type or paste '''mailto''' and pause while Firefox filters the list. You should get one row with a drop-down on the right that lets you choose your mail program or site. If your program is not selected, go ahead and change it now. If it is already selected, try refreshing the setting by changing to another program or site and OK out of the dialog. Then go back and change it back. Does that make any difference? If I have misunderstood the email feature you're trying to use, could you describe it in more detail?